GL-B2200 Velica dropping wifi 2.4GHz

I have three meshed Velica devices. The sub-nodes are meshed with ethernet backhaul. Everything works fine, but after a couple of hours the wifi signal in the 2.4GHz band is dropped. This only happens on the sub-nodes.

The bottom light (internet light - see LED Indicators - GL.iNet Docs) turns blue and only the 5GHz frequency works. I noticed this because I have some devices which don’t support 5GHz, and some others are too faraway to connect to the 5GHz.

What I have tried, which doesn’t work:

  • Reboot the master
  • Reboot the sub-nodes
  • Reboot the wifi-cards on the master

What I have tried, which works:

  • Remove the sub-nodes from the mesh, factory reset them, and pair them again.

Attached, you will find my network and wireless files, (1.7 KB) the master node.

Can someone help me to solve this problem?

Can I ask, when you see the 2.4G drops, is the 5G still on?

As you said the Internet LED turns blue, means that the Internet is down. When the Internet is down, the subnode turns off its wifi, both 2.4G and 5G. Doing this because your other devices can roam to other nodes, otherwise there is no Internet.

Can you make sure the subnode and main node are in good range?

Yes, the 5GHz remains on. That is also why it is weird. I still have internet connection as well, even when the 2.4GHz dropped.

I though that maybe it was because of DHCP leases from my ISP router which is connected to the main node, but that’s also not the case. No new IPs were assigned.

I use the mesh with Ethernet backhaul, it seems to work on both WAN and LAN ports on the sub-nodes. So the range shouldn’t be a problem

I might add that this only happens after a couple of hours, but it is a persistent situation :frowning:

I have called developer to check