GL-B2200 (Velica) setup: No uninitialized router found

I’m trying to set up a GL-B2200 as a home router with the app, and I’m pretty sure it’s paired, but setup fails with the following message: “No uninitialized router was found in the local network. Please make sure that your router is turned on and has not been set up.” (Before it was paired and restarted, it would tell me to go to my phone’s settings to turn on Bluetooth.)

I’m pretty sure it hasn’t been initialized, and scanning for wifi hotspots, I don’t see any SSIDs that probably match the router. I’ve tried setting the router up connected to the modem by ethernet, and I’ve also tried setting it up disconnected, and I’ve even performed a factory reset under both conditions in case it set itself up or something.

What else can I do to troubleshoot it, and is there any possibility of bypassing the app for setup? I’m more comfortable in the command line than on a phone, but no setup seems to mean no SSH.

What is your phone model?
What is the LED status of the B2200 when connected to your modem?

Can you make sure about the following:

  1. Power on B2200, connect to your modem. Wait it boot, the Internet and Power LED should both be on. Now use a pin to reset the router by pressing the reset button for 10 seconds. Just wait the router reboot
  2. Use the smartphone app to do the setup. It should find the B2200.
  3. If you have other B2200 you can also try the other one.

My phone is a 2021 Motorola Edge, and I always make sure to wait until the LED is white.

1-2: This is how I did it, and the result was “no uninitialized router was found…”

3: I don’t have another B2200, and this B2200 is intended to replace the current non-B2200 router.

If you just have one B2200, you can just use a cable, connect to B2200’s LAN and set it up.

Not sure what is happening with the app.

It’s working now, thanks!


Sent from my GL-B2200

1 Like