GL-E750 Mudi - Connect to Laptop without Wifi

I am a newbie and have two issues. First off, the wifi and vpn are definitely working on my router. However the home screen says “Bell No Internet” (I’m in Canada). I have a sim card installed in the router. When I am logged into the admin panel, the internet appears to be connected. So not sure if it is or not? Any advice or instruction to ensure the sim card is indeed working?

Once I figure out the above, my second question is how exactly do I connect my laptop to the router’s internet data connection? I will be travelling by car through the US and Baja, Mexico. In the US, I want to buy an ATT sim card for the router so I can connect to the internet whilst in the car (when hubby is driving). Can you please assist me with this?

Can you post a screenshot of the Admin Panel showing that the router is connected to Bell and shows up as Green (not White)? Is the APN correctly set automatically or manually?

You can connect your laptop to the router either over wifi or over Ethernet cable (using the included port replicator). You should do this in order to test that Internet access is actually working.

I do not work for and I do not have formal association with GL.iNet

I can’t answer whether it was set up automatically or manually as I am not sure what I did. The Mudi doesn’t have an ethernet port nor does my phone. Do I use the adaptor that was included in the package? Do I need to change the setting. It is set on repeater at the moment.

The included USB-C port replicator has an Ethernet port on it, in addition to the charger port:

The Admin Panel screenshot does show that the router is connected to Bell over 4G and has been assigned an CGNAT IP address. It also shows a small amount of Upload/Download data. If you connect your laptop to the router over Ethernet cable to the USB-C port replicator, then you can test whether you can access the Internet.

You should turn of Repeater in order to use the 4G modem.

Thank you so much for this information. My laptop does not have an ethernet port. I bought an adapter today to connect the ethernet cable to the laptop. I have plugged in the various cables as configured above.

I disconnected Repeater option and the VPN on the Mudi router. I can see the LAN client on the Mudi dashboard when I connect everything. I cannot get the cable section connected. I tried the DHCP option as I have no idea what the IP address of the sim card is. It doesn’t work. Please see the screenshot and provide any advice.

The screenshot does not show the entire Admin Panel, so I cannot see the status of the other connections. It looks like the router is successfully connected to Bell and your laptop is successfully connected to the router, so you should be able to access the Internet.

If you follow the Internet - GL.iNet Router Docs 3 link, it tells you how to set up the router to work properly.

If your devices do not have an Ethernet port, you can connect to the router over wifi via the GL-E750-524* SSID’s shown in the screenshot…

OMG. All I did was turn on the Mudi and then have the laptop connect to GL-E750 wifi and voila! it worked. I can’t thank you enough. I now fully understand three different options on the Mudi router.

Dropping a note here: the dongle can be used either as a WAN connection or as a LAN connection. If it is used as a WAN connection, the Mudi will get its internet connection from the laptop; if it is used as a LAN connection, the Mudi will route its cellular connection to the laptop, which is what most people want.