GL-E750(Mudi) how to fix TTL value 65

How to fix TTL 65 for GL-E750

You have settings in the modem

1 Like

I changed the value in the settings to 65, rebooted the modem. I go to the terminal and ping the Google Public DNS. But ttl still does not change to 65 and the value is 104. What could be the problem?

root@GL-E750:~# ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8): 56 data bytes
64 bytes from 8.8.8.8: seq=0 ttl=104 time=91.196 ms
64 bytes from 8.8.8.8: seq=1 ttl=104 time=81.753 ms
64 bytes from 8.8.8.8: seq=2 ttl=104 time=102.451 ms
64 bytes from 8.8.8.8: seq=3 ttl=104 time=118.311 ms
64 bytes from 8.8.8.8: seq=4 ttl=104 time=90.905 ms
64 bytes from 8.8.8.8: seq=5 ttl=104 time=90.421 ms
64 bytes from 8.8.8.8: seq=6 ttl=104 time=105.123 ms
64 bytes from 8.8.8.8: seq=7 ttl=104 time=88.721 ms
64 bytes from 8.8.8.8: seq=8 ttl=104 time=88.438 ms
64 bytes from 8.8.8.8: seq=9 ttl=104 time=88.098 ms
64 bytes from 8.8.8.8: seq=10 ttl=104 time=86.779 ms
64 bytes from 8.8.8.8: seq=11 ttl=104 time=88.449 ms
64 bytes from 8.8.8.8: seq=12 ttl=104 time=85.202 ms
64 bytes from 8.8.8.8: seq=13 ttl=104 time=86.873 ms
64 bytes from 8.8.8.8: seq=14 ttl=104 time=107.301 ms
64 bytes from 8.8.8.8: seq=15 ttl=104 time=88.026 ms
64 bytes from 8.8.8.8: seq=16 ttl=104 time=86.742 ms
64 bytes from 8.8.8.8: seq=17 ttl=104 time=87.319 ms
64 bytes from 8.8.8.8: seq=18 ttl=104 time=85.997 ms
64 bytes from 8.8.8.8: seq=19 ttl=104 time=85.690 ms
64 bytes from 8.8.8.8: seq=20 ttl=104 time=85.370 ms
64 bytes from 8.8.8.8: seq=21 ttl=104 time=93.064 ms
64 bytes from 8.8.8.8: seq=22 ttl=104 time=85.737 ms
64 bytes from 8.8.8.8: seq=23 ttl=104 time=85.423 ms
64 bytes from 8.8.8.8: seq=24 ttl=104 time=82.087 ms
64 bytes from 8.8.8.8: seq=25 ttl=104 time=89.685 ms
64 bytes from 8.8.8.8: seq=26 ttl=104 time=82.311 ms
64 bytes from 8.8.8.8: seq=27 ttl=104 time=90.050 ms
64 bytes from 8.8.8.8: seq=28 ttl=104 time=81.750 ms

You cannot check using ping.

ttl is the value that shows the upstream interface.

For example, my ttl is set to 64. It shows this value if I ping my gateway.
image

While ping to google will go through a lot of gateways and the ttl will be summed up.
image

1 Like

I can’t find that option page for the TTL, where is it?

Thank you

I tried changing the TTL as per the above method and when I ping my gateway it always shows as 64.

Ping the gateway of your 4G network?

It is available in modem manual config page.

My LAN IP is 192.168.80.1
I believe the modem is on 192.168.1.0 (that’s what it installs as on Windows). However, trying to ping that (from Windows) timed out - same from the Luci interface under “diagnostics”.

I don’t think you mean the LTE config. It is wan cable config?

No, it’s a USB modem. The router LAN IP is 192.168.80.1 which I assumed was the gateway too.

The 192.168.0.1 is the IP the modem normally gets when plugged in to a Windows PC.

Just completed some more testing.
I ended up pinging 127.0.0.1 from withing Luci (not sure this is correct) but found:

Changing the TTL in the modem settings made no difference.
Changing the TTL in th Luci firewall settings “iptables -t mangle -I POSTROUTING 1 -j TTL --ttl-set XX” worked.