GL-E750(Mudi) how to fix TTL value 65

You have settings in the modem

1 Like

I changed the value in the settings to 65, rebooted the modem. I go to the terminal and ping the Google Public DNS. But ttl still does not change to 65 and the value is 104. What could be the problem?

root@GL-E750:~# ping
PING ( 56 data bytes
64 bytes from seq=0 ttl=104 time=91.196 ms
64 bytes from seq=1 ttl=104 time=81.753 ms
64 bytes from seq=2 ttl=104 time=102.451 ms
64 bytes from seq=3 ttl=104 time=118.311 ms
64 bytes from seq=4 ttl=104 time=90.905 ms
64 bytes from seq=5 ttl=104 time=90.421 ms
64 bytes from seq=6 ttl=104 time=105.123 ms
64 bytes from seq=7 ttl=104 time=88.721 ms
64 bytes from seq=8 ttl=104 time=88.438 ms
64 bytes from seq=9 ttl=104 time=88.098 ms
64 bytes from seq=10 ttl=104 time=86.779 ms
64 bytes from seq=11 ttl=104 time=88.449 ms
64 bytes from seq=12 ttl=104 time=85.202 ms
64 bytes from seq=13 ttl=104 time=86.873 ms
64 bytes from seq=14 ttl=104 time=107.301 ms
64 bytes from seq=15 ttl=104 time=88.026 ms
64 bytes from seq=16 ttl=104 time=86.742 ms
64 bytes from seq=17 ttl=104 time=87.319 ms
64 bytes from seq=18 ttl=104 time=85.997 ms
64 bytes from seq=19 ttl=104 time=85.690 ms
64 bytes from seq=20 ttl=104 time=85.370 ms
64 bytes from seq=21 ttl=104 time=93.064 ms
64 bytes from seq=22 ttl=104 time=85.737 ms
64 bytes from seq=23 ttl=104 time=85.423 ms
64 bytes from seq=24 ttl=104 time=82.087 ms
64 bytes from seq=25 ttl=104 time=89.685 ms
64 bytes from seq=26 ttl=104 time=82.311 ms
64 bytes from seq=27 ttl=104 time=90.050 ms
64 bytes from seq=28 ttl=104 time=81.750 ms

You cannot check using ping.

ttl is the value that shows the upstream interface.

For example, my ttl is set to 64. It shows this value if I ping my gateway.

While ping to google will go through a lot of gateways and the ttl will be summed up.

1 Like

I can’t find that option page for the TTL, where is it?

Thank you

I tried changing the TTL as per the above method and when I ping my gateway it always shows as 64.

Ping the gateway of your 4G network?

It is available in modem manual config page.

My LAN IP is
I believe the modem is on (that’s what it installs as on Windows). However, trying to ping that (from Windows) timed out - same from the Luci interface under “diagnostics”.

I don’t think you mean the LTE config. It is wan cable config?

No, it’s a USB modem. The router LAN IP is which I assumed was the gateway too.

The is the IP the modem normally gets when plugged in to a Windows PC.

Just completed some more testing.
I ended up pinging from withing Luci (not sure this is correct) but found:

Changing the TTL in the modem settings made no difference.
Changing the TTL in th Luci firewall settings “iptables -t mangle -I POSTROUTING 1 -j TTL --ttl-set XX” worked.

@alzhao Hello . I ran into the same problem using MUDI . I had a sim card that could share internet (data ). I inserted it into the modem, on the display I saw the LTE logo as well as the inscription there is no Internet. I tried to change TTL to 65 in the interface as in your picture but that didn’t work either. What needs to be done so that the modem can distribute the Internet.

My steps:
Section Internet /3G-4G Modem >Manual Setup> More >TTL>65

This seems not a TTL problem.

Does it get IP from the tower?

Have you upgrade to firmware 3.215?

@alzhao Hello . Thank you for your answer . Unfortunately, I did not understand how to quickly solve this problem. When the SIM card was in the phone, the Internet worked, as soon as I inserted the SIM card into the modem, the display showed no Internet. The firmware is the latest, I always follow this. The display also showed the operator’s name.
I remembered after a while the inscription no Internet disappeared.
Please tell me how to fix this in the future so that I can use the modem?
Maybe I didn’t adjust some settings…

Can you tell me the data plan of the sim?

Data only or data and voice? Prepaid or post paid?

Can you clone the phone IMEI to the router?

Can you tell me the data plan of the sim?

The plan allows share data .

Data only or data and voice? Prepaid or post paid?

The tariff plan included 30 GB of traffic, calls, etc.

Can you clone the phone IMEI to the router?

I have not used this feature. If I’m not mistaken, you can clone the IMEI of the MUDI router. Did you mean it?

Set the IMEI of your phone to E750

1 Like

@alzhao thanks for the help

@alzhao Please tell me after I changed TTL how can I check his change? or do I just need to ping any address?

1. nano/etc/firewall.user
2. iptables -t mangle -I POSTROUTING 1 -j TTL --ttl-set 65

Will my change be displayed in the GUI for example?

No. The change in iptables does not display on the UI.

You need to display using iptables command, iptables -L or iptables -S

1 Like