GL-E750 no Internet (Telekom T-Mobile.de)

Hello,
My router is MUDI (GL-E750 Portable 4G LTE Router)

I am using a well known working SIM from Telekom (t-mobile.de) which is automatically recognized, connected, (I have an IP (10.26.8.xx) but no internet at all.

The SIM works perfect in many other devices.

I tried to set up the connection manually, but it is even worst (not connected).
According to Telekom, these are the parameters. | Telekom Hilfe

I am not sure where to set-up Authentication Type and APN-Type. These options are not listed in the MUDI configuraton web interface.

Very frustrating!!

It seems this would solve the problem:

I run into the same problem, but the given hints (switch to ttyUSB2 and back as well as killall -9 uqmi) do not get my device working.

Trying to switch to ttyUSB2 via the Webinterface i got the Error “Device busy”, doing the “killall -9 uqmi” i got the response “no process killed”.

Any further hints or what am i doing wrong?

thanks & best regards
Carsten

short update: switching to ttyUSB3 gives “kinda” (umts) internet-access with 14down/6up. when switching back to /dev/cdc-wdm0 no connection again.

normal LTE-speeds here around 120. obviously mudi has a problem with it…

ttyUSB3 mode is more compatible

dont know how i got there, but - after some try-and-errors editing /etc/config/network i somehow got the device on /dev/cdc/wdm0 working. rates up to some 40 down/12up.

however, not shure if it was important at the end, i inserted the auth-scheme and username/password for the apn exactly as given by t-mobile for their “normal”-use APN (they have some other, internet.v6.telekom or festeip.telekom): auth is PAP and username/pass was set to t-mobile and tm.

weird behaviour by MUDI was, that, even after i got a connection on /dev/cdc-wdm0 and some decent bandwith, the displayed showed “no internet”.

after reboot the display was as expected, showing 4+.

@alzhao - cellinfo shows its working on band 3 - the FAQs state, that the EP06-E is able to aggregate some band, 41/41 for example. how ca i force the EP06 to do band-aggregation?
And: The MUDI shows 4+ - is that still some kind of “UMTS”-bandwith? When and with what bandwith to expect will it switch to “LTE” ?

thanks for any clarification and for your help.

best regards

If you do not lock band, the modem does this automatically. There is no option to control which band it need to aggregate.

4+ should be LTE advanced, isn’t it?

Ok, youre certainly right. 4+ is advanced, just wanna know what your differentiations between lte/4g and 4+ as shown on the oled-display are. :slight_smile:

These info is read from the modem using AT command. It is info sent by the carrier. It may not mean faster because the real world speed is very different from different carriers.

You can refer to this article How fast are 4G and 5G? - Speeds and UK network performance

Hi @alzhao - many thanks for the clarification. I think the mentioned uk-values have a good match to the situation here in germany. i have a 5G huawei-chipset based router with dedicated external directional antenna for backup here at home, but unfortunately the local BTS has its 5G on the same Base-Frequencies as the LTE/-Advanced before, so no real big improvement - more marketing-like 5G-rollout - but up to 200MBps during nighttime where we previously had max 120MBps.

1 Like

Hey @cguenther,

i am also a customer of Deutsche Telekom and, despite the various approaches here in the forum, have so far only achieved a functioning Internet connection with reduced speed (approx. 15MBit) via ttyUSB3. Every attempt (all possible variants of APN logins) to enable higher transmission rates (LTE) via cdc-wdm0 has so far failed. I’m connected immediately (green light and a stable connection); however, no domain is resolved and calling up a domain directly via IP is also unsuccessful. I have the impression that there is a connection (with Internet connectivity) for a few seconds, but this is quickly gone again. In the meantime, do you have an idea which of your trial and error actions in the /etc/config/network area could have brought a solution? Would it be possible for us to align our settings once? I would be very happy about a feedback - I’ve already spent some time with various solutions from this form - unfortunately without success. Best regards, Thorsten

I got a feedback about working Telekom settings

APN: internet.telekom

Auth: PAP

Proto: qcm

User: telekom

Passwort: telekom

Hey, @alzhao - you made my day! your telekom settings are working. I think the proto: “qcm” have made the difference. I’ve tried it with the proto: “auto”- setting.

Thank you!
Best regards,
Thorsten

Does the User and Passwort matter?

No, i do not think,

i used:

APN: internet.telekom
Auth: PAP
User: telekom
Passwort: telekom
Proto: Auto

before and i did´t get internet connectivity.

But at least using ttyUSB3 should work. No?

ttyUSB3 worked all the time but with much lower speed.