GL-E750 running tailscale as an exit node

Has anyone been able to successfully get tailscale running as an exit node?

I’ve been attempting to get tailscale running as an exit node on my GL-E750 after updating it to the latest stable firmware version (4.3.8). I’m unable to get an internet connection after updating the firmware to version 4.3.8, which is running OpenWrt 22.03.4 r20123-38ccc47687 and following the guide to configure tailscale as an exit node (being sure to follow all the exceptions for OpenWrt 22.03):

I’ve got a Synology NAS on my home network running as an exit node and wanted to also run the travel router (Mudi E750) as an exit node via 4G LTE as a failover network in case my home network goes down (in addition to usage while traveling).

Any ideas?

I don’t know if the following post will be of any assistance. I know that currently Tailscale is in beta, and doesn’t support GL.iNet devices as exit nodes.

I’ve unfortunately already tried to do this and it did not work for the Mudi (GL-E750). Were you ever able to get it to work for you (I noticed you also had the same issue as reported on that other post)?

Also, from my understanding, the mentioned post is attempting to get the router to connect to an exit node - resulting in dropped connections. I’m attempting to configure the travel router as an exit node.

Just confirming, are you trying to use Mudi the (GL-E750) as an exit node or another device?

When I was trying to get my Beryl AX (GL-MT3000) to route traffic to another device as an exit node (that’s when I was having an issue). Using the Firewall rules as described in that link above resolved that particular issue for me.

My understanding, it’s currently not possible to use the GL.iNet routers as exit nodes.

Correct - I’m trying to run the exit node on the Mudi (GL-E750) itself. The OpenWrt link I listed in my original post has the steps to be able to configure an OpenWrt 22.03 device as an exit node, yet some firewall settings configured within the Mudi seems to be preventing this.

I suspect a clean OpenWrt 22.03 install will likely work as expected, however then I forgo the GL.iNet configured feature set, which is not ideal.

Also of note: I was able to get the exit node on the Mudi to work only once, before it stopped working completely.

This happened the first time I brought up the Mudi as an exit node: I connected my Android phone to my tailnet and selected the Synology NAS as the exit node, checked my external IP on my phone and the correct public (home network) IP address was being reported. Then selected the E750 as the exit node from my Android phone, refreshed the IP page and the Mudi’s external IP (running 4G SIM) was reported. A few minutes later: my Android phone had no internet connection. I could not get this to work again since.

Maybe later today I will attempt to reset the Mudi’s firnware to the current stable release (4.3.8) and attempt a bare minimum configuration to see if I can reproduce my earlier success (and pull the logs from the Mudi to see if anything stands out).

I got the exact same results as earlier: the first time the exit node is hosted within the GL-E750 the internet seems to work for a short while and then stops working shortly afterwards. The logs did not help narrow down the root cause of this either.

I also saw that others are running into a similar issue over on the tailscale forums:

The correction made there does not seem to correct the issue on my side.

As a note, the following steps seems to be the extent of what would be required (in case others would like to attempt this themself):

Anyone have any other suggestions to troubleshoot this issue?