GL-E750 SSID issue

Hello. I have bought a new GL-E750 a few weeks ago and I have a little question. When the router has no SIM card in it and/or isn’t in repeater mode (connected already wirelessly to the main router), its SSID can’t be found by the client device. The only way to get access to the Mudi, under these conditions, is by Ethernet.
Once I get access using Ethernet and connecting to the main router network, then the SSID of the Mudi gets visible. Is this normal?
Thanks in advance for your help!

Is the SSID on 2.4 GHz, 5ghz-channels or both?

Are the channels selected to auto?

Try band 20 (not 40 or higher) for both 2.4 GHz and 5 GHz.

For 2.4ghz channels try 11, 6, 1 (not auto) and see if there is any difference (band 20 for all)

For 5Ghz try channel 36 and band 20, if not fixed try a different channel but keep the band at 20

The SSID is on 2,4 GHz (I’m not using the 5 GHz). The band used is 20. Initially the channel was set to 7, later I tried with your suggestions (11, 6 and 1) without any different results.
The SSID of the Mudi can’t be detected by a client unless I provide the Mudi with an internet source (such a SIM card or a main router connection -wireless in my case-). The detection afterwards is almost instantaneous (once the Mudi gets internet, its SSID becomes visible). I’m using the latest firmware.

What client(s) cannot detect the Mudi’s SSID? (Android, Iphone, Windows, Ubuntu/Linux)

Did you test it with at least 2 clients? (Just to make sure that the client is not configured to connect to it only when is Internet)

If you only have one client, change the Mudi’s SSID and see if it is any change

I tried with Android (smartphone) and Linux (PC) with the same results. The SSID of the Mudi has been changed 3 times (I wanted to discard any character issues of the SSID name that could possibly be affecting the detection of the SSID by any client).
As I stated before, once the Mudi gets an internet source, automatically its SSID becomes visible. Without an internet source, the SSID of the Mudi isn’t visible, therefore (in my case) I can’t connect to it wirelessly.

After some hours of trial and error I decided to revert the firmware, reboot and start again. After doing so, the Mudi fixed all its past issues. I tested it for an hour (rebooting, installing complements, etc) without a fault, therefore, I think, I could mark this issue as solved. I’d like to thank Silkweb for his/her time trying to help me.


I do not upgrade the firmware unless:

  1. There is a serious problem with the current firmware
  2. The firmware was released at least 2-3 months ago, so other users have tested it