GL-E750 Wifi Repeater Mode not Autoconnect Wifi after location change

Hello all,

The router GL-E750 is operated without a SIM card. I only use the WIFI repeater function. There is an OpenVPN configured with killswitch function and AdGuardHome is active. The router works in (router) mode.
The firmware is 3.215.

There are three Wifi SSID from different location configured in the router. When I change the location it does not automatically connect to the wifi from the location. Also the own WIFI hotspot of the E750 is not displayed on the computer.

It seems as if the router does not do a wifi scan or auto connect to known wifi’s in the location.
If I go back to the last working location then the router connects to the wifi and the router’s own wifi is also visible. In between changing the location the router is turned off and on again by me.

Curious solution
If I change to a known location and it does not connect to the wifi network, I can solve the problem by connecting to the E750 router with the LAN adapter and calling the router address in the web browser via LAN connection without logging on to the router website. Then the router finds the wifi, the router automatically connects to the known wifi in the location and the router’s own wifi is also visible on the computer and I can work normally with the router via wifi without LAN cable.

Does anyone have an idea what is the problem? Thanks.

Will reply to you from our

I was able to find the Problem. The problem seems to be only when configuring only a 2.4G access point on the router.

I only had the 2.4.G Wifi access point enabled on the GL-E750 router and the 5G Wifi access point disabled. When both frequencies are active for the AP, the E750 works normally.

This seems to be a bug that if you only set up a 2.4G AP in the E750 then it does not automatically find a wifi after a location change with a different SSID and the hotspot from the E750 is also not visible.

What remains a mystery to me, if you only have a 2.4G AP wifi on the router and the problem exists, you can solve it if you briefly establish a LAN connect to the router via the LAN adapter. Apparently then restart some routines for the WIFI AP and then the router works normaly even if only the 2.4 G Wifi AP is active.

Ok I can live with it that I set up both wifi frequencies 2.4G and 5G for the wifi AP in the E750 even if I don’t need 5G in my setup. :slight_smile:

1 Like

It is strange. What is the 2.4G wifi channel it used?

I can no longer recreate it.
I had once done a factory reset.

It now works as it should. is sometimes murphy law

1 Like