GL-iNet 6416A v1 as VPN gateway - I got stuck

Dear all,
my GL-iNet 6416A v1 says it’s connected to the VPN provider, and obviously it really has some sort of internet connection, because it was able to check for new updates (firmware v2.25 is installed). But the computer that’s connected to the 6416A via patch cable can’t reach the internet. No ping, nothing.

The computer and cable connection are both ok - I can reach the 6416A on and configure it. I just can’t get to the internet through the 6416A. I’ve been tinkering desperately since days, so maybe I spoiled something at some point. It is my understanding that the problem most probably is the bridging between RJ45-LAN and Wifi-WAN. Went back to factory settings a few times already to start from scratch. So, I guess I need some good advice now. Am I missing anything? Any ideas?

Thank you!

The router has Internet itself because it doesn’t need to use vpn to connect to Internet. While you pc has to get data forwarder to vpn.

Can you tell me which is your vpn service provider?

Is there any data in/out in the vpn interface.

When you said “No Ping”, did you try ping domain name or IP directly. Does it say dns not resolved?

Alzhao, thanks a lot for your immediate response!

My vpn provider is PIA ( I used 2048 because 4096 didn’t seem to work.

The OpenVPN client page states a little data in/out: Data received: 24.66K, Data sent: 19.59K. Both values increase very slowly every few minutes. Maybe some connection stay alive protok0ll.

I tried to ping both domain name ( and IP directly ( It doesn’t say “dns not resolved”. In both cases it says “connect: Network is unreachable”

I see, PIA should work with v2.25.

Did you upload files before you upgrade to v2.25? If yes, please purge all the files upload again. Generally this does the trick.


No, I didn’t upload anything before upgrading. After upgrading I installed macchanger, which I removed right now, then rebooted, but still no connection.

Btw. I tried with and without “Force VPN - No Internet if VPN is not connected”.

Also I tried to connect when VPN was disabled (“Enable” not ticked), without success.