Gl inet Android app freezes (Grey screen) after clicking to open it


I just received the new GL-MT3000. I have a Samsung S22 Ultra device and I am not able to open the Gl iNet app. After installation, when I click on the icon, the application is frozen on a gray screen. Nothing is happening.

So I have to go through Google Chrome for configuration. Everything went well.

Does anyone have an idea why the app freezes on opening even after several uninstalls?


Is this the app you have installed?

Hello, yes it is this app

What is your GL-MT3000 firmware version and compile time?

What language is your phone system in? A known bug is that some system languages can cause this phenomenon. We are fixing it.
If your phone system is not English, you can temporarily switch to English. After opening the App, change the language of the App to English in the settings page in the sidebar and then switch your phone system back to your language.

A few weeks ago I had the GL-AXT1800 model. I could open the app and it worked fine.

Now gray screen.

My Android is in French but the App worked before.

The firmware is v4.1.3

This may be caused by the most recent update of the App version. I tried switching the phone language to French and it does cause the 2.0 version of the App to freeze.
We will release a fix for this in a few days.

Any idea when the update will be available?

We just release v2.0.1, please try it on the google play.

Thank you very much it works.

I have another question related to the App.

Is it possible to display the Adguard status on the main page? Actually same as when we access through url where we see the active and not active services. Without having to go through the Plugins icon, where we must then click on the service to see its status. Simple constructive comment :wink:

We are considering this too.