GL.iNET App on Android: Network storage error

I get

when trying to access usb storage
works fine on pc

tried resetting router
changed passwords and users
tried anonymous etc.

please help

If you use the SMB server to share files, use the app called Owlfiles instead of the glinet app, it’s really good and works great, give it a try trust me, that’s what I use on iOS/Android to share files quickly. Use glinet for monitoring your network and some basic stuff

Thanks Steve - sounds like a plan…¬¬

What bugs me is the app worked fine until I did a router factory reset…Aaaargh
I deleted app wiped cache everything - its like it remembers the passwords

I used to use the glinet app before but after I tried Owlfiles I switched to that one, it’s simple to use, it is compatible with SMB, WebDav and a los of connection types. It also has a clean interface, I’ve personally had a great experience.

Steve -
working with tech support - this issue is resolved

you cannot have special characters in the router admin password
I had a " which it didnt like
I think @ is ok

1 Like

THANK YOU. I spent wayyyy too long trying to figure out the issue. I had a “$” in my admin password. Not sure why this would trip it all up, but removing it fixed the issue.