GL-iNet AX1800 OpenWrt firmware

What exactly would be the difference between the images you posted, and the latest beta release from the github?

Only change the kernel vesion to 5.4, the other is the same.


I have been working on Kernel 5.4 build myself just finding issues when compiling with everything set to compile.

Here are the build instructions for the 5.4 kernel from the chinese GL forum:

git clone
cd gl-infra-builder
python3 -c config-wlan-ap-5.4.yml
cd wlan-ap/openwrt
/scripts/ target_wlan_ap-gl-ax1800-5-4 luci.
make -j17

Which is what my script a few posts up does, apart from setting up the entire build enviroment on a clean Debian/Ubuntu install before hand.


## Update and install required packages for Gl-Inet Intra Cross Compile ##

sudo apt update && sudo apt dist-upgrade -y 
sudo apt install -y build-essential gawk gcc-multilib flex git gettext libncurses5-dev \
libssl-dev python3-distutils zlib1g-dev neofetch qemu-guest-agent python3-yaml rsync sshpass \
binutils bzip2 diffutils grep libc-dev libz-dev perl rsync subversion unzip libncurses5-dev \
zlib1g-dev g++-multilib  git-core libssl-dev ocaml sharutils re2c \
libusb-dev bin86 sharutils openjdk-*-jdk libxml-parser-perl libboost-dev curl bc patch \
python3-distutils-extra libsnmp-dev liblzma-dev libpam0g-dev cpio xz-utils wget make bash g++

## Clone Intra ##
git clone
cd ~/gl-infra-builder
python3 -c config-wlan-ap-5.4.yml

## Complete Intra Setup ##
cd ~/gl-infra-builder/wlan-ap/openwrt
./scripts/ target_wlan_ap-gl-ax1800-5-4 luci

### Run Menuconfig to adjust things ##
cd ~/gl-infra-builder/wlan-ap/openwrt/
./scripts/ > ~/gl-infra-builder/wlan-ap/openwrt/
cat ~/gl-infra-builder/wlan-ap/openwrt/
read -p "Edit the .config file and then press any key to continue... " -n1 -s
make menuconfig

## Compile ##
cd ~/gl-infra-builder/wlan-ap/openwrt/
make -j$(($(nproc)+1)) V=sc defconfig download tools toolchain clean world
#make -j1 V=sc ## Diaganostics
1 Like

You are doing a lot more, have you tried just the above to see if you have the same compile issues?

I have and just using the luci.yaml file it will compile without issues, my solidus1983.yaml is based of the luci.yaml but with additions however another user on here is helping out and we are finding things like kmod-tun is causing the issue thus far.

The whole idea for my build is to have a decent router setup but with the abillity to customize it after from a mirror.

Also to the reason why i made a script is for others to also compile for themselfs with a helping hand.

1 Like

Well i pin pointed the issue to be with the solidus1983.yaml, however after being able to build and flash the firmware i found several issues.

Firstly Uboot is still bricking routers if you flash custom openwrt firmware, yet flashing the same image via WebGUI works fine.

Also compiling everything no select as modules causes issues as well during the image creation. I know its early days however its fustrating having to recompile everytime, Why can’t it be like my Linksys compiles i do not know.

New script:

cat <<EOF >
echo " _____  _           _  _   _        _                                                      ";
echo "|  __ \| |         (_)| \ | |      | |                                                     ";
echo "| |  \/| |  ______  _ |  \| |  ___ | |_                                                    ";
echo "| | __ | | |______|| || . \` | / _ \| __|                                                   ";
echo "| |_\ \| |____     | || |\  ||  __/| |_                                                    ";
echo " \____/\_____/     |_|\_| \_/ \___| \__|                                                   ";
echo "______  _  _         _      ___  __   __ __   _____  _____  _____                          ";
echo "|  ___|| |(_)       | |    / _ \ \ \ / //  | |  _  ||  _  ||  _  |                         ";
echo "| |_   | | _  _ __  | |_  / /_\ \ \ V / \`| |  \ V / | |/' || |/' |                         ";
echo "|  _|  | || || '_ \ | __| |  _  | /   \  | |  / _ \ |  /| ||  /| |                         ";
echo "| |    | || || | | || |_  | | | |/ /^\ \_| |_| |_| |\ |_/ /\ |_/ /                         ";
echo "\_|    |_||_||_| |_| \__| \_| |_/\/   \/\___/\_____/ \___/  \___/                          ";
echo "______         _  _      _   _____              _                                      _   ";
echo "| ___ \       (_)| |    | | |  ___|            (_)                                    | |  ";
echo "| |_/ / _   _  _ | |  __| | | |__  _ __ __   __ _  _ __  ___   _ __ ___    ___  _ __  | |_ ";
echo "| ___ \| | | || || | / _\` | |  __|| '_ \\ \ / /| || '__|/ _ \ | '_ \` _ \  / _ \| '_ \ | __|";
echo "| |_/ /| |_| || || || (_| | | |___| | | |\ V / | || |  | (_) || | | | | ||  __/| | | || |_ ";
echo "\____/  \__,_||_||_| \__,_| \____/|_| |_| \_/  |_||_|   \___/ |_| |_| |_| \___||_| |_| \__|";
echo "                                                                                           ";
echo "                                                                                           ";

read -p "Press any key to continue setting up system build enviroment... " -n1 -s

sudo apt update
sudo apt dist-upgrade -y
sudo apt install build-essential gawk gcc-multilib flex git gettext libncurses5-dev libssl-dev \
python3-distutils zlib1g-dev libncursesw5-dev xsltproc rsync wget unzip python python3-distutils python3 \
rsync subversion swig time libelf-dev java-propose-classpath ccache ecj fastjar file g++ python3-setuptools \
openjdk-11-jdk bcc libxml-parser-perl libusb-dev bin86 sharutils zip fakeroot make sed bison autoconf automake python3-yaml

## Clone Intra ##
git clone
cd ~/gl-infra-builder
python3 -c config-wlan-ap-5.4.yml
#python3 -c config-wlan-ap.yml

## Complete Intra Setup ##
cd ~/gl-infra-builder/wlan-ap/openwrt
#./scripts/ target_wlan_ap-gl-ax1800-5-4 luci
./scripts/ target_wlan_ap-gl-ax1800-5-4 luci solidus1983

## Update packages ##
cd ~/gl-infra-builder/wlan-ap/openwrt/
./scripts/feeds update -a
./scripts/feeds install -a

### Run Menuconfig to adjust things ##
cd ~/gl-infra-builder/wlan-ap/openwrt/
./scripts/ > ~/gl-infra-builder/wlan-ap/openwrt/
cat ~/gl-infra-builder/wlan-ap/openwrt/
read -p "Edit the .config file and then press any key to continue... " -n1 -s
make defconfig
make nconfig

## Compile ##
cd ~/gl-infra-builder/wlan-ap/openwrt/
make -i -j$(($(nproc)+1)) X V=sc defconfig download tools toolchain world
#make -j1 V=sc ## Diaganostics

Copy and paste that into a ssh terminal then run chmod a+x then run it!

With this script it will build a working version. Infact i am hosting such a basic image over on

If i compile for everything it will simply brick no matter how you flash which is what i am looking into as its something to do with kconfig it looks like.

Right i made a two step compile hopefully OPKG will work right now.

REMOVED Due to user bricking their device.

These are Kernel 5.4 versions. Please test and let me know.

Please remember to flash via the Gl-iNet stock firmware WebGUI!
Flashing via Uboot will brick the device! as Uboot and OpenWRT seems to be broken.


Release v4.0.1_beta2


yo, really liking that ASCII artwork!

that localcase letter i, perfect

1 Like

LOL yep i am old school like that.

However i can’t compile again, because something in the gl-inet repo changed again where its not loading profiles, so figuring how to fix that in the script.

Had same issue with the config folder being renamed to configs so had to output that differently on the script not porfile folders is no longer a symlink now i have to sort that mess out.

Need advice…
I have a FLINT GL-iNet AX1800 coming…
I’m planning on using it as a Gateway router with a Wireguard VPN connection to my VPN Provider (Surfshark which just allowed Wireguard ROUTER Configuration)…So the GL.inet router will just be serving as the Wireguard encrypt/decrypt device…After the FLINT router it will go to my regular router’s WAN Port via Ethernet (My network is entirely Ethernet wired)…My question is should I upgrade to the latest BETA firmware once I get the FLINT or stay with Stable. I know the latest BETAs are on newer Kernels and the Stable is on Old stuff…I’m thinking to go with the new BETA unless there’s some reason not to…I’m staying with my current router as there’s some stuff that I need (Master Browser, etc.) that the FLINT won’t do…But I plan on using the FLINT as a GATEWAY router to do the WIREGUARD encryption (Which my current router can’t do without a lot of scripts and customizations. Thanks.

It depends I think.

But one very good reason to upgrade to 4.x beta is that vpn policies are far more better, also the wifi felt more stable for me than with the old qsdk.

Other than that theres not a really down side I know off by upgrading to the beta.

Thanks xize11 for your input… You just reminded me that I have an exception on my current router for my VOIP device so I’ll probably just wire the VOIP device directly to the FLINT and in that case I may use the policies or make an exception for the VOIP device on the FLINT so it doesn’t go through the VPN.The wifi won’t be used unless I travel and take the FLINT with me.

This is just a note concerning connecting VoIP ATA to the Flint (and other OpenWRT routers) that SIP ALG may be enabled by default, which tends to cause problems and may have to be disabled.

I do not work for and I do not have formal association with GL.iNet

1 Like

Thanks wcs2228…Yeah I always disable that on any router that I use at home…Ooma which is my VOIP adapter doesn’t require it.Thanks for the heads up on that.

Got the Flint Router today…I immediately upgraded to 3.14 and then the latest 4.01Beta2 firmware…
Downloaded the Wireguard Conf file for one of Surfshark’s Servers and immediately connected…
BUT…I kept getting CLOUDFLARE DNS Servers rather than Surfshark DNS…I even configured it manually and told it to reject any other DNS servers from the clients…But still continued to get CLOUDFLARE DNS…
Surfshark techsupport was baffled as well and we tried various things but kept getting CLOUDFLARE DNS.
So I decided to flash back to the older stable 3.14 firmware…Same thing…The wireguard connection connected immediately but I was getting CLOUDFLARE DNS Servers even when I had it configured manually for Surfshark DNS Servers…Completely baffled. Left it for Surfshark to hopefully get back to me…
Anybody have any ideas or seen similar with their VPN provider? I also verified it was not something configured in the browser (Firefox latest)…Reverted back for now to my other OpenVPN router…I tried both the LAX and SanJose Surfshark servers and both configs would connect right away but I had CLOUDFLARE DNS??? Going to flash it back to 4.01Beta2…

1 Like

I had the same problem. I downloaded snapshot 3.15 and vpn providers are working fine. I have

hmm I’m not sure, but have you tried to use vpn when the dns settings are set to default/automatic under More Settings>DNS ?

I believe you can’t use both via the UI if you want to prevent dns leaking.

Yes…I had it first set to Default/Automatic. And was getting CLOUDFLARE…Then I put it in manual config for DNS and told it to ignore client DNS (They’re all set to DHCP anyway) and was still getting CLOUDFLARE…And that was the same for both 3.214 and 4.01Beta 2. Nothing we tried worked and I could only get CLOUDFLARE. I assumed it was something with SURFSHARK’s configuration because they just went live with Wireguard Router Configuration but thought I’d ask here since the router is new to me and thought maybe those DNS servers were hard coded in somewhere that could possible be edited out. I did not see any 3.215 firmware in the download section for the Flint router.