GL.iNET AXT1800 Tailscale fail to connect

Hi Everyone.

I’m a newbie and very new to Tailscale and wondering why my GL.iNET tailscale running apps unable to ping my home node?

Here is my network which consists of 2 RPI as my home node and allows me to go to my local network. Tested to access my home network from my Android and iOS (with tailscale connected) However upon binding tailscale beta on AXT1800, I can’t even ping the 2 nodes from my Mac connected to AXT1800. Using Terminal I am also unable to ping the 2 nodes. So Basically tailscale completely binds and I can ping IP Assign from Tailscale from AXT1800, however, I can’t do anything.

Does anyone know how to fix this? I want this to work however no clue how to fix it.

From this picture, you can clearly see that AXT1800 is already connected. However, I cant ping RPIProxy1 or RPIProxy2 from it.

AXT1800 running FW 4.2.3 and Tailscale 1.32.2-dev-t

Please run command ip route show table 55 to check if there have routing rule to your RPIProxy1 or RPIProxy2 on AXT1800, and do you have subnet routes enabled on Tailscale Admin console?

Hi @fangzekun

thank you for the reply sorry for the late response. From OpenWRT terminal inputting the run command, I will get all the IP from my machine connected to Tailscale. And yes I can ping the IP no problem, however, I can’t still ping my home local network share by rpiproxy-1 or rpiproxy-2.

On my tailscale GL.inet menu the only enable switch is enable Tailscale the rest is disable. Do I need to enable WAN or LAN?

Do I need to set up local IP from my rpiproxy to include GL.inet local IP? or just my rpiproxy local IP should be sufficient?

CleanShot 2023-09-20 at 08.42.38

From my connected notebook behind GL.inet 100% unable to ping any of tailscale networks nor the local home IP.

I hope I can solve this problem and again thank you for the assistance.

You can download v4.4.6 beta 1 at GL.iNet download center and try it again after upgrading.And you should enable LAN and have subnet routes enabled on Tailscale Admin console if you want to acccess devices connected to AXT1800 from rpiproxy.Can you draw a network topology if issue still exists?Thanks!

Hi @fangzekun ,

thanks for the quick reply. In my case, I would like to access the local rpiproxy-1/2 home network and not the other way around. both rpiproxy-1/2 already open their routes in, however from behind gl.inet I can’t see the 192.168.x.x at all. So I hope this will clear the miscommunications. Again thanks for all the assistance.

The accept-routes option is disabled on v4.2.3, so you can’t see their subnet routes on AXT1800. Please download v4.4.6 beta 1 and try it again after upgrading. And you should enable LAN and have subnet routes enabled on Tailscale Admin console if you want to acccess rpiproxy from devices connected to AXT1800,too.


Still no luck. Installing 4.4.6 beta 1 and enabling both WAN and LAN… Still unable to connect to my rpiproxy-1 IP from behind GL-Inet nor able to ping the local IP.

P.S., from openWRT CLI, I can ping rpiproxy-1 and my home local IP. So it’s now moved up a little further.

Unsure if I should reset the setup?

Could you please draw a network topology diagram to discript your problem?And execute the following commands and PM me the result:

 tailscale status
 ip rule
 ip route show table 55
 ip route

Same issue here. I’m on version 4.4.6 release1. I’ve tried the steps mentioned here but I’m in the same boat as @KingRichard. I can ping devices on my tailnet from an ssh session on the AXT1800 by ip and name but clients hooked to the AXT1800 can not.

I’m a bit confused that nslookup does resolve a client on one of my tailscale subnets ( but ultimately returns can’t find no answer

Could you please execute the commands mentioned above and PM me the result, too?

Ok, I sent the requested info.

I was able to get this working on stable version 4.4.6 with the help of @fangzekun

The part that was stopping me from connecting to my lan clients was I needed to enable Accept subnet routes that other nodes advertise. on my pfsense gateway. Once i did that I could connect (via IP) to clients on my home lan.

As I understand it we cannot yet access clients over tailscale via dns yet, so to get around this issue I added the entry’s into the AXT1800’s Hosts file Network > DNS > Edit Hosts
Once I did this everything worked as expected.

Here is my tailscale settings for reference:


Hi there - new-ish atx1800 and Tailscale user here. Also trying to use my atx1800 to access my home systems and sometimes use my home location as an exit node over tailscale, similar to @KingRichard and @egates.
Also able to use atx1800 ssh session to ping tailscale IP of home subnet router, but no joy for LAN clients connected to atx1800. Also, I am able to connect to the home subnet router with my laptop (chromebook - running android tailscale client, also my android phone running tailscale client).

ATX1800 vitals: kernal - 4.4.60, OpenWRT - OpenWrt 21.02-SNAPSHOT r16399+165-c67509efd7, tailscale 1.64
Here’s my tailscale settings:

I’d be happy to PM results of network commands above.

Thanks in advance!

As I posted to @fangzekun, I’m also having troubles connecting to my home subnet via tailscale on my atx1800. After following @egates post, I am able to ping an IP address and DNS name that is in the atx1800 Hosts file - via the OpenWRT CLI, but I can’t ping the IP (nor DNS name) from the laptop (chromebook) device that’s connected via wifi to the atx1800.

Thanks for any thoughts.


Only other thing I did notice is I have this enabled on the tailscale website (Machines > gli axt1800 > Edit route settings). Might be worth a shot, I believe the clients that don’t have tailscale installed require their subnet be advertised to complete the connection.

@egates - thanks for the thought…
Turns out, my problem was adding the LAN side subnet route ( to the destination’s subnet route rule - my packets were bouncing all over the place :man_shrugging:t3:
When I removed that, things started working :+1:t3:

1 Like