Gl.iNet Beryl AX not turning on or showing any lights

Plugged in and doesn’t show any lights or connectivity at all, I tried ethernet and looking on my wifi connections. Also tried to reset it using the support guide, and nothing happened. The charger is working because it charges other devices.

If it is a USB-C charger which can negotiate multiple voltages, then it may not work if you are using a USB-C to USB-C cable (2 of my standard chargers do not power the Beryl AX if I use USB-C to C, the one with a USB-A port will work if that USB-A port is connected to the Beryl).
Try a USB-A to USB-C cable or a charger that can only output 5V (with at least 2A output)

Im using the charger it came with. I have the SFT1200 model and it charges that one just fine.

Have you tried using Uboot to try and debrick in case the reset didn’t work correctly?

When I made this post I tried that. The lights weren’t blinking at all so it was more bricked than what it usually is supposed to be, I guess. I tried today and it worked until the very end, while updating the firmware it stopped blinking again after waiting for over 5 minutes. Powering on to try again and now its the same as before, rarely showing any lights.

Did you try using a different power supply? I saw somewhere (might not have been on these forums) that some people had reported problems with the official power supply.

Yeah, tried another usb-c charger I had and different outlets.

Seems the power connector is defective.