GL-iNet Firmware-Download Server broken?

Since several days I can’t access your server for firmware downloads. When calling I get a white page, in the upper left corner appears the text “Error: [object Object]”, nothing else, no list of directories and files.

System ist Debian-Linux 9.5 with latest chromium browser, but I get the same result, when calling the above URL from a Samsung Tablet PC.


I just tried the link using both Chromium and Firefox on Linux Mint. Got the page with no problems. Also tried it with Firefox and Chromium on Mac OSX with no problems.

You might try for a sub-page. I have been using:
for the past few days without problems.

Is there any debug/developer mode in chromium to check the detailed info?

Can you try a different browser?

The download page actually contains nothing more than file list.

@alzhao and @mainer

Thanks for reading and replying.

I checked it again with a pc directly connected to the internet (without any firewall or router): everything appeared as usual.

Going back to the original pc I disabled adblock on the router (MT300A): everything appeared as usual.

The culprit was the adguard list in adblock, which contains an entry blocking every URL ending in Because leads to the gl-inet firmware download server was blocked, too. Disabling the adguard list in adblock solved my problem.