Gl.iNet GL-A1300 (Slate Plus) - WireGuard to Fritz!Box 7530

Dear Forum,

I am currently trying to establish a WireGuard connection between a router (Gl.iNet GL-A1300) (in another country) and my Fritz!Box 7530 in Germany.

The following worked:

  • WireGuard Server (maybe wrong term, I’m not an expert) set up on Fritz!Box. Set up via “Connect single device”.
  • Tested WireGuard with multiple smartphones in multiple countries (iPhone and Android) (QR scanned, connected) → worked fine.

The following does not work:

  • Downloaded configuration file from Fritz!Box interface and set it up on GL-A1300 → It connects according to UI, but there is no internet connection.
  • When I restart Fritz!Box, the connection is also lost according to UI of GL-A1300 and then restarts → so there is a connection but no internet connection


  • I manipulated and tested the configuration file I was able to download in several ways: ListeningPort added, DNS changed,… - everything does not work
  • I was able to download another configuration file from WireGuard mobile app (smartphone connection works perfectly, after all). I also tested this file on GL-A1300, it does not work.

You can find the logs of GL-A1300 below.

Can you please help me to get the connection working also between GL-A1300 and Fritz!Box?

Thanks for your help and best regards


Mon Aug 21 18:40:20 2023 daemon.notice netifd: Interface ‘wgclient’ is setting up now\n
Mon Aug 21 18:40:20 2023 kernel: [ 5024.442124] wireguard: wireguard-hotplug IFNAME=wgclient ACTION=KEYPAIR-CREATED\n
Mon Aug 21 18:40:21 2023 daemon.notice netifd: Network device ‘wgclient’ link is up\n
Mon Aug 21 18:40:21 2023 daemon.notice netifd: Interface ‘wgclient’ is now up\n
Mon Aug 21 18:40:22 2023 user.notice wgclient-up: env value:T_J_A1_1=object T_J_V_ifname=string J_V_address_external=1 USER=root ifname=wgclient ACTION=KEYPAIR-CREATED N_J_V_address_external=address-external SHLVL=2 J_V_keep=1 T_J_V_ipaddr=array HOME=/ T_J_T2_mask=string HOTPLUG_TYPE=wireguard T_J_V_interface=string J_A1_1=J_T2 J_V_ifname=wgclient T_J_V_link_up=boolean T_J_T2_ipaddr=string LOGNAME=root DEVICENAME= T_J_V_action=int K_J_A1= 1 J_V_ipaddr=J_A1 TERM=linux SUBSYSTEM=wireguard PATH=/usr/sbin:/usr/bin:/sbin:/bin J_T2_mask=24 CONFIG_LIST_STATE= J_V_interface=wgclient K_J_V= action ifname link_up address_external keep ipaddr interface J_V_link_up=1 J_T2_ipaddr= J_V_action=0 T_J_V_address_external=boolean N_J_V_link_up=link-up PROTO_IPADDR= T_J_V_keep=boolean PWD=/ JSON_CUR=J_V K_J_T2= ipaddr mask CONFIG_SECTIONS=global AzireVPN Mullvad FromApp group_433 group_3400 group_2718 group_932 peer_2001 group_9021 peer_2002 group_6947 group_3207 peer_2003 peer_2004 group_6987 peer_2005 CONFIG\n
Mon Aug 21 18:40:22 2023 user.notice mwan3[7453]: Execute ifup event on interface wgclient (wgclient)\n
Mon Aug 21 18:40:23 2023 user.notice mwan3[7453]: Starting tracker on interface wgclient (wgclient)\n
Mon Aug 21 18:40:25 2023 user.notice firewall: Reloading firewall due to ifup of wgclient (wgclient)\n

From the log we can tell the wireguard tunnel is set up successfully but the default route is not ready.
Please paste the friz!box wireguard conf file, with keys, etc masked.