GL.iNet GL-A1300 & Tailscale


I have a setup were I use a lenovo mini-pic as my tailscale exit node in my house. I also have tailscale in my iphone and mac and it works like a charm. I am trying to connect to my exit node from a GL.iNet GL-A1300 router but the moment I turn on the “Custom exit node” switch from the interface all the devices connected to the router can’t connect to the internet. I can see the router along with the rest of my devices in my tailscale account and I have advertised the IP ranges(I think) but still it won’t work.
How can I solve this?

What’s the firmware version of your A1300? Can you help to make sure lenovo mini-pic has accepted routing rule of A1300? Please follow the attached document for further check.Thanks!

Using Custom Exit (631.7 KB)

hi, I am currently on firmware version 4.5.

This guide was helpful. I think the only thing I hadn’t done was step 3, DNS settings. I did that and a warning I was getting before, when I would turn on “Custom exit node”, is not there anymore. Unfortunately though, I still can’t load any pages.

Are my IP settings ok as per step 4 in the guide? I am not very sure.

The setup the exit node, you need to enable in 3 places.

  1. Enable the exit node on your PC/Laptop.
  2. Enable the exit node on the admin console
  3. Choose your exit node on A1300 GUI.

You can use ssh cell and type tailscale status and check if the exit node also up in the route.