GL.iNet GL-AXT1800 LAN2 isnt working at all

Hi there,

I’ve got GL.iNet GL-AXT1800 & have configured it as AP mode so i can use it to expand my network & add WiFi too.
Following router manuals I was able to change it to AP mode & it works perfectly with my network setup & wireless clients are able to connect & browse.

Wanted to make use of two additional ports LAN1 & LAN2 to add my TV & SAT Box, here what Ive started to have issues with it …

ATX1800 wasn’t flashed or updated when i received as i wanted to test it out b4 i head on with it.
LAN1 interface was working properly
LAN2 wasn’t at all, checked logs & saw eth1 briefly up & connected as 10mbt, then it went off!

I’ve decided to flash it with latest beta to see if that would solve, it didn’t.
Checking (br-lan) noticed that both eth1 & eth2 both shared same MAC, went ahead & changed eth2 to a different number (last octate) & my TV got an IP & started working.
Sat-box didn’t work at all no matter what MAC address i assign to it from interface, changing out cables between devices, renders the same result one device is on other is not.
Which confirms that cables/devices are working, ATX1800 ports aren’t.

all of above was done with (power cycle) to each change made.

Any help would be great, i hope this not a defected item.

Thank you

Have you tried 4.1 r1

Maybe the port is defective

Yes … just did same result
Got this of from amazon
Did contact support which redirect me to write a note to seller GL.iNet them selves

Yes this is the correct and fastest way.

Seems like my message wasn’t relayed properly to vendor.
Don’t know what amazon have done
Just had a chat with support, they cant find any messages to vendor at all.

Could please assist me in this ?

Thank you

Pls send an email to support at and cite this thread.