GL iNET GL-MT300N-V2 - unable to access settings via IP

I’ve just bought the GL iNET GL-MT300N-V2 and I’ve been following the instructions but when I try to enter it doesn’t load.

I’ve read multiple threads of others having the same issues and the solutions presented didn’t work for me. Here’s what I’ve tried

  • On my mac, in both Safari and Chrome (both tried in Private/Incognito mode) I’ve tried going to:

  • I’ve rebooted the router by holding the button down for 4 seconds

  • I’ve reset it to factory settings by holding the button down for 10 seconds

  • I’ve tried it both ways the instructions suggest, connecting by LAN and connecting via Wi-Fi

  • I’ve done all of the above on my Mac and on my iPhone

None of these methods have worked.

If I try the Wi-Fi method, I can see the network, I can connect to it, but can’t access the settings.

If I try the LAN method, I can access the internet without issue, but I can’t access the settings.

I don’t know if this makes any difference but I have a static IP that I recently purchased from my ISP, but I access my ISP router settings on so its not like its coincidentally the same IP

Ultimately what I’m trying to do is have this GL router connect to my existing router, I want it to produce a separate network that I can connect to where all traffic runs though a VPN via OpenVPN. So the end result will be my Mac could connect to WiFi network 1 which is my original setup and doesn’t route though a VPN, or my Mac could connect to WiFi network 2 which is the GL router and all traffic goes via the VPN.

Any ideas on how I can troubleshoot further?

did you join the routers wifi/connected it to your pc via lan cable before trying to browse its admin interface?

check if and what ip adress is given to your device.

The first step is to check what is the IP address your pc got from the router and also check your connection.

Before the above is clear you don’t need to go far to check other things like reset the router.

Ah I solved it, I had to unplug it from the main network so it was just the GL iNET distributing a wifi network, then on my Mac I connected to it and held down ‘alt’ while clicking on the WiFi symbol which gave me the router IP. I typed this in and it sent me to the controls. Leaving this comment in case others have this issue in the future.

1 Like