GL.iNet Mango: Wifi issues with mt76_wmac

Wifi issues with mt76_wmac vanilla openwrt 19.07.4

I am exploring wifi issues happening once every few days. When the prolem appears the wifi wan connection to the AP stops and doesn’t ever recover. Even when unloading the kernel module for mf76. So far the only revocery is rebooting.

The setup is wlan2wlan with wan: wifi client - lan: wifi AP.

significant loglines look like: mt76_wmac ... timed out...

any ideas for a workaround or even fix?
thanks 1000x
Mischa


config:
SoC Type: MediaTek MT7628AN ver:1 eco:2

config wifi-device 'radio_bgn'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'platform/10300000.wmac'
        option htmode 'HT20'
        option disabled '0'

config wifi-iface 'nw_ap_bgn'
        option device 'radio_bgn'
        option network 'lan'
        option mode 'ap'
        option isolate '1'
        option ssid 'xxx'
        option encryption 'psk2'
        option key 'xxx'
        option disabled '0'

config wifi-iface 'nw_wifi_client_bgn'
        option device 'radio_bgn'
        option mode 'sta'
        option network 'wwan'
        option encryption 'psk2'
        option ssid 'xxx'
        option key 'xxx'
        option disabled '0'

MIPS: machine is GL-MT300N-V2
[ 12.351439] mt76_wmac 10300000.wmac: ASIC revision: 76280001
[ 13.390246] mt76_wmac 10300000.wmac: Firmware Version: 20151201
[ 13.396271] mt76_wmac 10300000.wmac: Build Time: 20151201183641

DISTRIB_ID=‘OpenWrt’
DISTRIB_RELEASE=‘19.07.4’
DISTRIB_REVISION=‘r11208-ce6496d796’
DISTRIB_TARGET=‘ramips/mt76x8’
DISTRIB_ARCH=‘mipsel_24kc’

Linux md-home-wifirouter 4.14.195 #0 Sun Sep 6 16:19:39 2020 mips GNU/Linux

I am not sure about the reason. But one possible way you can try is set the BSSID (mac address) of both AP and sta interfaces.

In old 7620 chipset, there are limitations. The first 12 bit of the mac address should be the same.

For example:
If for AP, mac is 00:01:02:03:04:05
The STA mac can be 00:01:02:03:04:06, but 00:01:02:03:04:0a does not work.

Thanks for your suggestion. I’m not sure but have you seen this problem with the MTK7628NN? I mean there must be a reason why GL.inet doesen’t actually use the official wifi driver in their release for this chipset. But as far as I can see there are no official supported vanilla openwrt ports of their driver used?