GL iNet only connects through cable, not internet

I have the Gl iNet and have it configured. It used to work and then I had issues, so I did a reset and started all over. While box is connected from WAN to my modem and the LAN to my laptop, I have internet on my laptop. Wireless is turned on and I did not change any settings but as soon as I unplug the Ethernet cable from my laptop and try to connect to the WiFi, it says connected without internet. My mobile devices say the same. I need the WiFi feature to work as I have cameras that I use on this devise. The cameras are only WiFi cameras. I’ve tried using the WiFi repeater setting and connected the box to an open network but I still get connected without internet. I’ve reset the box three times and now have to leave the office, which is an hour away. That is why I have cameras. I just went back into the Wireless and turned on the guest wireless and now my phone is actually connected. This makes no sense but I can now at least hopefully get my cameras working again. Any suggestions on the regular Wireless? Thanks


I would try not just a reset but reloading the latest firmware as per the uboot instructions

This seems strange. Can you pls check if, when you disconnect your LAN cable, the IP addresses of your phone on wifi changes to something else?

Pls give screenshot of your web panel in normal mode and in abnormal mode.

Unfortunately, it will be a while before I will be back at that office to “play” again. Since I was able to get the guest WiFi to work for my camera’s I’m not too worried. I’ll figure out the the IP address and respond again at that time but it might be a month or two before I’m back. Sorry