Gl-inet router says 'Wrong Key' on wifi repeater join

I’m getting the same error after setting the time/date via SSH :frowning:

What exact version (image) do you use? Have you tried latest BETA ( openwrt-mt1300-3.212-0301.bin from BETA page)?

The Mango and Beryl use proprietary wifi drivers, I think, and at the moment this is in flux. So the latest snapshot addresses some of the issues in the Beta, but work is still going on. @alzhao suggested a further reworking in a week.

Mango 3.212 snapshot
Beryl 3.211 stable
Not affiliated with GL-iNet–just a user

Firmware is 3.212, was the snapshot from 2022-03-20 10:04:26. I tried the beta before, had the same problem.

try the beta again and this time set date/time :wink:

Just tried it again with my lab router. Even a few minutes offset in time cause that wrong key.

  • downgraded to openwrt-mt1300-3.212-0301-BETA1.bin
  • scan, select WiFi-AP, enter password
  • connect SSH, request date/time → 7 minutes offset
  • press [Join] → “wrong key
  • set correct date/time
  • press [Join] again → “Success!”


Can you try firmware 3.203?

connected successfully on 1st try even though the firmware downgrade reset the date to “Mon Aug 9 08:30:57 UTC 2021”.


Will you file a bug yourself or shall I open a new thread about ths date/time-reset-by-firmware-upgrade?
Same with WebInterface only updating time but not date, should be fixed as well.


I am on it. I record this to investigate.

When the dust settles, perhaps someone could explain how time could figure into joining a network? The router doesn’t know the time when it boots until it connects to the internet, but you should be able to connect to the router without any internet connection at all.

Any update on this issue. The current snapshot still doesn’t work. Wrong key continues to popup. :frowning:


I think the Beryl beta3 fixed all wrong key problems.

Can you describe the problem a little bit so that we investigate more? e.g. what is the upstream wifi device, ssid and key length, special characters etc.

The upstream wifi SSDI is iPhone, key is srkifh6uetek0 13 characters and all lower case no special characters.

I did notice that on the web interface when I synch the date and time with the local computer the date and time zone updates but the time remains wrong.

I just tried,

Router: Beryl MT1300
Firmware: 3.212 beta3 GL.iNet download center
iPhone 13: hotspot with key srkifh6uetek0

Repeate can connect without problem.

What is your browser?

Having the same issue, pretty frustrating as I bought Beryl specifically as a Bridge.
FW 3.211 connecting to Fritz 7490
Time and date set correctly via cli

For Fritzbox can you go back to firmware 3.203?

Hi Alzhao,
I did as you suggested and the device successfully connected as a bridge. Thank you for this.
Will the issue with Frits be resolved in a future update?

I bought a FritzBox and it is on the way. I hope it can go through the customs.

Next issue. I connect my devices to bridged Beryl and they get address and connect to internet. Upon reboot of Beryl, they cannot reach internet.

I change Beryl to use, same as Fritz. Mixed results. Devices on Beryl can ping Beryl but no internet. Devices on Fritz cannot ping devices on Beryl, or Beryl.