GL-M2 Cannot connect to Three UK 5G - SIM card not registered

I have recently bought a GL-M2 with 5G modem (Quectel RM520N) and I am struggling to get the 5G connection up and running on it and I think I need some advice to get it running correctly.

I use the GL-M2 with GL-AX1800/Flint through the USB port on AX1800 and the carrier is Three UK. I have tested the Three SIM card on a spare iPhone Xs and even on the GL.iNet GL-XE300/Puli and the SIM works with both.

However I just cannot get it to work on the GL-M2 after trying with permutations of different modes (3G/QMI/QCI) with different possible Three UK APNs - “” and “3internet” from search engines - all have failed to work. And I have tried to reboot the modem and the router as well and still no luck.

I got a “SIM card not registered” error.

I also contacted support from Three UK for any configuration advice but they insisted I use the auto configuration and keep directing me to the manufacturer of the 5G modem so no real help from the service provider either.

Any help/advice would be appreciated, and many thanks in advance.

First, you need to check that the antenna of the module is inserted correctly
You can then try to connect to 4G first by executing the following commands over ssh.
gl_modem -B 2-1 AT AT+QNWPREFCFG="mode_pref",LTE
Please use the double quotation marks in English format

gl_modem -B 2-1 AT AT+CFUN=0; sleep 1; gl_modem -B 2-1 AT AT+CFUN=1

Select apn for manual connection

Thanks for the reply!

I can confirm the antenna is installed correctly.

I have executed the ssh commands as given:

This is the setting I am using now - I only used the APN and set nothing else:

However still cannot seem to connect:

There’s a problem here

gl_modem -B 2-1 AT AT+CFUN=0; sleep 1; gl_modem -B 2-1 AT AT+CFUN=1

Thanks for the updated command, now it seem to have run correctly:

Although the problem persists.

An additional info - I have used the coverage checker tool from 3 UK and have confirmed my area should have 5G signal indoor.

The current command only confirms that the connection is normal

Apologies but not sure I understand? Is there anything I can try please?

The current problem is not connected but is the sim card displayed registered?

I am not connected. The router is also saying the SIM card is not registered.

Can we support it remotely?
Technical Support via GoodCloud.tar (192 KB)