GL MANGO - VPN troubleshooting

Hi ,

I have Gl mango and having the below issue when connecting to VPN

  1. Firmware is upgraded.
    Mango is connected to power supply / apple adapter.
    I logged into admin panel , changed the WAN port to Use as LAN . Plugged the Ethernet cable: one end connected to mango and other end connected to my modem.
    Internet works fine.
    I went to open vpn client, uploaded my config file entered password and clicked connect: it shows connection successful. Looks good so far.
    I’m in a different country and the vpn config file is for different country. So i go to check my ip : google search whatsmyip - just confirming my phone device is connected to the GL via wifi.
    The search result shows up as my home IP address. This should not happen. It should show the vpn IP.
    I have tried holding the restore switch for 4 seconds, rebooted and tried all over again. Same issue.
    I have double checked if VPN connection and config file is correct. I can surf internet , but it keeps using and showing my home internet.

  2. 2nd issue;

I tried connecting the mango with my home wifi instead via repeater option this time. Uploaded vpn config file and used the lAN cable connected to my playstation and the VPN works fine. I was very happy about this. The next day, i switch the mango on and it wont connect to the internet at all.
I tried connecting via wifi and it says incorrect password and unable to acess the admin panel. I did a reset and it worked.
After lots of testing i figured out that it my mango device gets turned off : it somehow disables the repeater option and is not connected to my home wifi anymore. So for me to make sure it works i have to keep the mango box switched on, which is not ideal.

Would appreciate if someone can help me with the above two issues, preferably i’d like the mango to be connected via LAN to my modem and other devices i would want to connect to the mango’s wifi using VPN services.

Many thanks in advance.

You have the wrong connection. Here is why:

When using WAN port as LAN, it means you have two LAN ports but the router still works in Router (NAT mode). You should connect to Internet using repeater. By connecting WAN port to your modem and LAN port to your PC, it bridges (this is wrong way to set up bridge) your PC to the modem. So the Mango router does nothing. VPN does not work.

To set up bridge, you need to set the router in AP, Extender, WDS mode. When you do this, VPN is not working any more.

I cannot understand this. Mango router should be always turnned on, right?


I’ll try to be more clear ;

Unfortunately I’m using my iphone to set this up. No pc.

I unboxed the device.
Turned it on.
Connected via wifi from my phone to GL- got onto admin panel , did the upgrade of firmware.
Clicked on use as LAN.
Connected the Ethernet cable: one end on mango and other end on my router.
Internet was working at this point.
Went to open vpn- did all the steps and clicked connect. It showed connection successful.
Vpn is showing green and there is internet.
Now when i go to whatsmyip: it shows my home ip.
I’m in Australia and the vpn client is USA.
Somehow it is ignoring the vpn. Even though it’s connected.

I then gave up on the LAN method and tried repeater option: so mango connected to my home wifi
I then connected the lan cable from mango to my playstation and connection was successful. I checked my ip on my PlayStation and it showed United states ip.
So it works via repeater option.
The only draw back is: i have to keep the mango turned on at all times.
If it gets turned off:
it does not recognise internet or my wifi
It says incorrect password (goodlife) when i try to troubleshoot with my phone, wont connect to the GL wifi. The only way would be to reset it (10 seconds) and do all over again.

turnned off, you mean reboot?

So when you reboot, it does not connect to your wifi and you cannot connect to Mango?

If this happens, it means that Mango kept trying to conenct to your wifi. In such situation, you may not connect to its own wifi because it is signal radio router.

But as it is your own wifi network, Mango should be able to connect to it succesfully after reboot. Did you save the SSID and enabled automatically scan and reconnect?

About vpn, do you use wireguard or openvpn?

If is wireguard, there may be bugs and it is fixed in 3.211 beta GL.iNet download center

Thank you taking time in looking into this.

SSID is saved. Have ensured that it is set to auto scan and reconnect.

I tried to turn off the yellow box.

No internet
Tried to reset it- nothing
Tried to acess admin panel- incorrect password error.

I did a hard reset 11 seconds hold. And re did the whole process.
It’s like if it turns off- it does not like connecting automatically to my home wifi. :cry:

Ideally i want the LAN method to work.
Where LAN is connected to mango and my modem. And i connect all other device using GL’s wifi - using VPN.

I’m using open VPN client. My friend uses the beryl who uses the same vpn provider with no issues.

Thank you

My two cents: you’ve got this all wrong.

The VPN client will connect everything on the Mango’s network to your VPN provider, and nothing on your modem’s network. So your cabling with the WAN port as a LAN port will never work.

You should have the WAN port on the Mango acting as a WAN port, and connect it by cable to your modem. Then connect all your other devices to the Mango wifi. That way your modem will hand out an address on its network to the Mango’s WAN port, and all the traffic will pass at 100mbs over the cable. The Mango will then be making a VPN tunnel to your provider over that cable, and everything connected to its wifi or LAN port will go over the tunnel. The internal switch will handle the cabled traffic, the CPU will do the VPN part, and the wifi part will handle the wifi.

If you go the repeater way, then the Mango’s wifi is doing double duty: handling all the traffic between your modem and the Mango, plus all the traffic to its own wifi network and LAN work. That will work, and that’s why your playstation experiment worked. But now the switch isn’t doing much, the throughput on wifi is at least halved, and the CPU is still spending its time handling the VPN, with little time to do other housekeeping.

I think your problem with the Mango on/off cycle may be time. It takes a while for it to connect in repeater mode to your modem, and then reset its wifi for its own network, and then setup the VPN connection. I’d give it a good 5 minutes before you give up on it. Also, I wouldn’t turn it off. It’s using no power to speak of.

OT: the Beryl is a different beast because it has two radios and is much faster. Same setup, except you can use one radio for the WAN and another for the LAN.

Why do you want to do this. I have no idea.