Gl-mifi 4G modem no longer works with v3 update

I have an old GL-Mifi that was originally meant as an AT&T device. (As I recall.)

I am using it now with Telnyx (one of the IoT SIM providers), or would like to.

When I first plugged it in, it was running very old firmware (v2 series) and worked fine.

When I updated it to v3, it’s stopped working. Instead now I get this

" SIM card cannot be registered. Please check: 1. You are using the compatible modem for your carrier; 2. Whether a specific APN or data plan is required."

What seems to happen is it registers, then doesn’t, then reregisters.

The carrier does see the registration and provisions it. (Telnyx offers a debug dashboard.)

This appears to be a problem with the device, not with the carrier.

I have tried forcing the APN. This does not help.

Is there a way to flash the firmware on the modem? or what would have changed with upgrading to v3? I can’t go back sadly.

Please check the originally firmware version (V2)of your MIFI, Do you have any records of the firmware bin file?

I do not.
is there a way to tell from looking at the filesystem or such?

would it be possible to get a latest v2 firmware somehow to test with?

Please leave me a email. I will send you the v2 firmware.

use jb4422

do you have suggestions for how to debug this, why it would be different for v3 vs v2?

I have send a email with the latest V2 firmware. Please check the mailbox.

it doesn’t work. I don’t know what is going on. I am going to guess something about the latest update changed something in the modem firmware and now it doesn’t want to work. It didn’t even want to work with an AT&T SIM. I tried going back to the 2020 firmware for v3 and that still does not work.

I decided I cannot afford to spend more time on this, and wanted an external antenna anyway since it is going in a rack in a datacenter, so I bought a spitz and am moving on. The Spitz worked first try with the SIM.