GL-MiFi 4G Smart Router - Modem doesn't work

Hi Folks

I just received my GL-MiFi 4G Smart Router … I inserted the data sim into its dedicated slot properly as described in the user manual. I then connected to the default WiFi (GL-MIFI-xxx) but couldn’t see the internet. I logged in to the firmware to see the modem configuration and did the following:

  • Go to Internet Status > New Connection.
  • I selected my country (Egypt), and my operator (Etisalat). The firmware automatically selected the device as (/dev/cdc-wdm0 (qmi)) and the APN (
  • I modified the APN to (etisalat) as this is what my operator says and this is what I already have on my other data sims from the same operator.
  • I left the Dial Number intact.

On the Modem Connection section, I can see a signal (sometimes 2G, and sometimes 3G). Also the Modem is shown to be Connected. Yet, the line below says (Connecting to the internet) … and 3G/4G LED on the modem never switched ON.

I can only connect to the WIFI without being able to connect to the Internet. I don’t know what’s the problem and how to resolve it. Please help!

Did you reboot router after insert sim?

I figured out the problem. It was that the router doesn’t save configuration if Safari is being used. I tried Chrome and it now worked.