Gl-mifi AT&T LTE settings

Hello!

I just received my gl-mifi device with an EC25-AF modem and have inserted a brand new AT&T (USA) SIM card but I can’t seem to get the settings correct.

I tried auto setup as well a bunch of settings in the manual setup page. I will get an IP address from AT&T but when I try to go to www.google.com I get an AT&T redirect saying that my account doesn’t have any data. I have a prepaid SIM card with 18GB data and I have confirmed this with AT&T. I have also confirmed the IMEI number with AT&T.

What settings should I choose in the gl-mifi manual setup? Anyone have an EC25-AF card working in a gl-mifi with att? If so, would you mind sharing the following (which will not uniquely identify your device):

Device:
Service: (if set)
APN:

And do you have anything set for pincode, dial number, user name, password? I understand these should be blank but wanted to check.

Thanks for your help! I look forward to getting the lte working!

Mike

I am running firmware version 3.023.

Thanks again!!

Mike

Try going into the manual setting.
Change APN to broadband.
Make sure Pincode, Dial number, Username and password are blank.then click apply.

Hey Sean! Thank you for the info. I factory reset the gl-mifi to clear out anything I might have done and set the apn to broadband with the rest of the fields blank. I get an IP address but when I try to go to any website I get the att redirect claiming I have no data.

The device setting is /dev/cdc-wdm0. Is this the correct device?

Thanks!

Mike

I was thinking about using this device when I travel but I have not found great success in getting internet connectivity with it. Everything seem like it should work but when I can get a connection its in the 2 - 3 Mb/s range which is really not great. I can get 30 Mb/s when using my iPhone as a personal hotspot sitting just a couple of feet from the GL-MIFI which is getting 2 - 3 Mb/s. That’s a 10x difference. I’ll be getting an EP06-A modem later this week and will try that but if that doesn’t bring consistency and better speeds then I think I may have to give up on the thought of using a gl-mifi when I travel. It needs to be better than connecting through my phone and right now it’s not even close.

Thanks again!
Mike

Hi.
My modem settings will be different as I have a Sierra card in it so can’t help you on that.
I am using one of the $29 a month at&t ebay specials with unlimited data so that may change things as well.

Hello,

You can test the following firmware to get more useful information

Hello,

Thank you for the new firmware! I have installed this on my GL-MIFI and now I am at version 3.025. I noticed there are different options for APN now. For AT&T 4G LTE, which APN should I choose? Options include; nxtgenphone, ims, phone, wap.cingular, PRODATA, tfdata (there is a second tfdata in the APN list). As for Cells info, I have two Cells listed. One has a rat of WCDMA and the other shows a rat of LTE. I assume I am actually connecting to the LTE version. Single strength is pretty low where I am right now so tomorrow I’ll put this in my car and see if I can find a stronger signal. Thanks for the quick firmware recompile!

Cheers!
Mike

You can try auto-connect first.

Will do. Next, I seem to be getting a very low signal strength. I have disconnected the stick on antenna and connected a 9dBi high gain antenna but there is no difference in signal strength. Is there an antenna that might provide a better signal when I am in a low signal area?

Also, I connected the external antenna to the same connection that the internal stick on antenna was connected to but I noticed that there are 3 connections on the modem card and 1 on the back of the motherboard. As I understand it, if the LTE antenna connection is on the far left of the modem, the center connection is GPS but what is the right connection and the connection on the bottom of the motherboard? The WIFI signal is strong without an antenna and I don’t need a GPS antenna, just trying to get the best 4G LTE connection possible.

Thanks for all your time and information!

Mike

There are many antennas out there.
I am wondering if you may have accidentally purchased a wifi antenna instead of an LTE antenna.
Even then, there are different LTE antennas with different bands.
A plus 9dBi antenna designed for 1900-2100 MHz will be something like minus 10dBi at 700Mhz.
I purchased this:

Its only 3dBi, but its its 3dBi on all bands.
I then connected with this:


I then mounted the antennas using the cut outs at the side of the GL-MIFI
Using both antennas gave me a significant increase in speed and signal.
The complete setup is pictured here:

Although 3dBi may not sound like much, Its significantly more than the internal antenna, which not only has a lower gain, but is also inside the box and next to internal electronics.

I think you are correct that they are wifi antennas. My mistake! But, as you said, the internal antenna is not doing much better. I ordered the same antennas you have. The picture you sent is basically what I want to build.

As for which antenna connect to which port on the modem, did you plug one into WAN and the second into DIV (the two outside connections of the three available)?

Thanks again for your help and guidance! This is turning into a fun little project.

Cheers!
Mike

Hi.
You are correct with the connections. Its the 2 outer connectors.

I received the new antennas and an EP06-A modem. The new modem and antennas have made the connection stable but I only connect with 3G. Never 4G even though, in the same location my iPhone easily gets 4G LTE. Any ideas on why I might be connecting at only 3G?

Thanks!
Mike

Hi.

There are 2 things you can try.
Try setting the apn to broadband.
If that does not work you can try to encourage the modem to connect to 4g.
I was staying in a hotel with a moderate 4G signal but it would only connect to 3G.
I placed the router next to a window then rebooted. It came up 4G.
I then could move the router wherever I want and it now always connects to 4G.
Not sure why it needs a helping hand like that but it worked for me.

You can use AT command AT+QCFG=“nwscanmode” and AT+QCFG=“band” query network mode settings.

Thanks again to Sean. After I booted up the gl-mifi this morning and putting it in a window, I am now getting a 4G connection with the EP06-A modem. Its 2 bars so kind of low but its working and I am seeing speedtest.net speeds in the realm of 10Mb/s down and up. This is acceptable.

Thanks again for the info and guidance!

Mike