[GL-MiFi] - Ethernet Ports not working

Hi All,

I have here 2x MiFi’s but am unable to get either to work in a stable condition, both are running firmware v2.271.

On the first router the LAN port appears to be working fine but the WAN port refuses to stay up, it just about gets a DHCP lease but as soon as I try to do anything with it (opkg update for example) the link drops and wont return until I unplug and replug the network cable. When the link does come up it’s only at 10Mbps.

The second router has pretty much exactly the same issue but on the LAN port, the only way I can access this one is by using the serial port.

Has anyone else experienced this issue or have any ideas on how to resolve? I feel fairly disappointed having bought two but can’t even establish a stable wired connection. I know it’s not an environmental issue as i’ve swapped absolutely everything.

Both have been tried on firmware 2.264 and openwrt 18.06.0

Many thanks in advance,


Except for serial, you can connect via WiFi and ssh to the router, right?

Can you get the log when the problem happens?

You can use the following

Exactly that yes, although WiFi I’m unsure of with the ‘clean’ firmware versions as it’s not enabled by default.

I haven’t got them with me right now but I’ll get you the output as soon as I can.


Logs below from the device with the LAN dropping issue, had a quick look through myself but nothing obvious stands out. You can see the behaviour at the end of each log after the device has been running for a while.




The LAN continuously connects and drops. I am asking other people to have a check.

From the log it seems a connection problem. Can you change an cable or try another PC so that it is not the problem of the pc.

Thanks for taking a look,

As stated in my original post I have swapped everything out that’s connected to the MiFi, even tried network cables of varying lengths. Is it possible I have two devices from a bad batch?

Should not. But I can get back for a test. PM you for return and test.