GL-MiFi: "No Internet" = Cannot connect OpenVPN

Hi,
1st circumstance;
Tested OpenVPN with a direct internet, OpenVPN is successfully connected = Good OpenVPN Profile.

2nd circumstance;
I am using a sim card. but, this system would not have an internet connection unless connected through OpenVPN.
But,
The GL-MiFi refused to let the OpenVPN try to establish a connection because of the “WARNING: No Internet” status.

How to set up the GL-MiFi to neglect “WARNING: No Internet” status, and force it to try to let OpenVPN start-up a connection?

This working flawless on OpenVPN on an Android phone.

noInternets

Are you using 3.105 firmware. I thought is limitation was removed.

maybe you can do this, first enable vpn when you connect Internet cable, then change to SIM card.

thanks.

I bought on Christmas December 2020, but still got old firmware. so others please check.
I just upgraded to latest firmware. but sometimes still cannot get it connected. “No internet” restrictions.

I use GL.inet mobile app, upload OpenVPN profile there, and then it works.
But to use the app, it’s really tricky as the user interface is not that user friendly.

take note newbies…