GL-MIFI - no wifi/4g after enabling Tor

I installed 3.102 on my GL-MIFI.
When enabling Tor, it goes to 50% and then becomes unresponsive. Can’t login to it locally and WiFi keeps saying incorrect password.
Anyone have a solution?
Tried SIMs from multiple providers.

No one here who can help?

@alzhao you have any idea?

Did you select random country? Pls use random.

Yes I tried both random and a country.

Also tried with LAN and a SIM. When enabling Tor, the device becomes completely inaccessible. No WAN or local connection possible (time-out).

Anyone can help?

I tried on other router it works OK.

I will find one MiFi and test.

Hello, have same problem:
GL-MIFI with fw 3.102 and I want to run tor.
Set RANDOM country or some exact - same.

Aug 13 00:01:33.000 [notice] {CONTROL} Bootstrapped 25%: Loading networkstatus consensus
Aug 13 00:01:54.000 [notice] {CONTROL} Bootstrapped 40%: Loading authority key certs
Aug 13 00:02:24.000 [notice] {CONTROL} Bootstrapped 50%: Loading relay descriptors
ERROR: Time out!

Ping on router is going, but webUI hangs for some minutes and next autoreboot.

Problem is the same with/without SIM.
WAN connectivity is superb, 100mbit.

Please help, thanks.

Just tried on mifi.

Tor is using too much memory and cannot run. Mifi is only 64MB RAM.