GL-MIFI only power light

i have a GL-mifi and i tried upgrading the firmware which i downloaded.
but after reboot, it only shows the green Power light and nothing else.
i cant even connect to it using wifi because the modem wont be found.
i tried connecting via lan to my pc and still wont connect. the gateway ip wont work.
i tried pressing the rest button (in the small pin hole) and power at the same time for 10secs and still only shows the green Power light.
i am stumped!
If i can upgrade it to the right firmware, im sure it will boot up properly but i cant connect any device to it and get to the main default page.
Doe anyone have the same problem that can guide me to getting my MIFI back to life?


ok. after mucking around trying to do uboot, its finally working.
now i have a problem, when i go to the default, it goes to LUCI.
how can i get back to the default webui page?
i updated the firmware with this one which i found on the main website. Firmware file: openwrt-mifi-3.029.bin

is this the wrong bin file?


I would recommend you use a newer version from here:

And after that delete your browser cache and access:

1 Like