GL-MiFi released 2.22 and Midnight Commander

Is there a reason why “use internal edit” (mcedit) is not working anymore in MC (Midnight Commander)?
I love the “mcedit”, and now I’m stuck using nano or vi for editing files :frowning:

Hi, I just tried to install mc using opkg and then it worked. But I don’t know how to use.

is “mcedit” one command from mc package?

F4 opens mcedit. Guest wants to have the internal edit, not external that is used now (I agree with him).

Freek is correct.
The internal edit is so much better.

@Freek and @Guest, forgive me, but how to press F4 and open mcedit? Should I do this in a ssh window? or when external mc is opened?

In a shh window, type mc, select file, press F4.

In current version some unknown editor is opened. We prefer to open the internal editor.

When in MC and pressing F4 it will open an editor looking the same as when you press F3.
F3 is only for previewing files.

However now when you press F4, it will open something looking like VI.

More info here: 10.10 - How to switch the editor in mc (midnight commander) from nano to mcedit? - Ask Ubuntu
Unfortunately this does not work with the MC coming with the 2-22 version :frowning:


I see. Does this working in v2.20?

What is the “Internal” editor looks like?

I’m not able to test this right now. Will do as soon as I’m back home (couple of days)

Using internal editor is a config option in make menuconfig:
CONFIG_MC_EDITOR=y … <= select internal editor

Freek, Are you saying that I need to recompile MC from source, or is the above info for alzhao?

@Freek, I see. I will try to compile these options when compile


Just tested it with the openwrt-mifi-2.20-7.bin version, and it’s also not working.

I never know it worked in any of our firmware, because we never use mc.

So I am a little surprised to see this question.

It was working fine with version 1.1 (see images)

I see. That was from BB1407. So the package configuration is changed in CC1505.

I see.
Anyway of getting this to work again?

One quick way is that you can just download the package from BB1407 and install using opkg.

I compiled mc with internal editor.

Rename mc_4.8.17-3_ar71xx.ipk.txt to mc_4.8.17-3_ar71xx.ipk (.ipk not permitted).

You rock !!!