GL-MT1300 (Beryl) - How to Achieve Advertised WiFi Speeds


I’m having a heck of a time trying to get the Beryl Router to achieve as close to the advertised 867 Mbps as possible

I have a computer that is capable of achieving ~650 Mbps on a different brand router
Using this same device, I can currently only achieve ~220 Mbps to the Beryl

Without consideration for the client machine, here is what I have done on the Beryl:

  1. turned off 2.4 GHz on router
  2. tried increasing bandwidth - attempted the 20/40/80 , the 40 only, and the 80 only options - no speed variance any way configured
  3. router has the WAN port connected to my switch (same switch as other brand router), client device is connected via WiFi
  4. tried various power modes (low, medium, high) - no speed variance
  5. tried positioning router in various place around the room - 1 ft away, 3 ft, 5 ft, 10 ft, etc - no speed variance
  6. confirmed cable is CAT 6 (same cable as used with other brand router)
  7. turned off all misc settings to prevent bogging down the hardware (i.e. DNS protection, firwall, etc)

Again, I can take my client machine, connect it to the other brand router and get ~650 Mbps data transfer speeds, and the SAME client with the SAME WAN cable to the Beryl router gets me ~220 Mbps speeds

Please advise on further troubleshooting steps to take. I understand that achieving a perfect 867 Mbps is unrealistic, but 1/4 the speed is just unacceptable. This is not an enterprise device, but I’m struggling to understand where the failure lies. Please assist

can you name the devices and the chipsets in both of them that are achieving 650Mbps?

the advertised 867 Mbps is the protocal speed.

The actual speed of 5G of MT1300 is aroud 300Mbps Download and 200Mbps Upload in my own test.
I can get 500Mbps Download/Upload (My ISP Limitation) by using Lan Cable connection.

What is the specs of your another router?

Also pls let me know what is the speed from WAN to LAN.

When your pc connect to MT1300, what is the speed displayed?


i like to share test info from a facebook group for your comparison

TP Link A6 Ac1200 - a single-core Qualcomm QCA9563 clocked at 775 MHz on a 1gbps fibre

Download: 432Mbps
Upload: 447Mbps

Did you have a fix on this issue? Facing same issue but no response from anyone and couldn’t find this topic on troubleshooting in google.

No fix at this time, been wrapped up in other projects and asked to leave this one as-is for now

The alternative WAP was a spare new out of box Ubiquiti UAP-AC-HD
The NIC in question was a Wi-Fi 6 AX200
Settings for both above devices were at default at ~650 Mbps

I’m not a WiFi expert - enterprise routers and switches are more my wheelhouse - and I understand there are hardware limitations, but I haven’t found a single online source that has been able to achieve near-optimal WiFi speeds with this device
Selling a device on its protocol speeds seems dishonest, and if there are caveats of having achieved these speeds in a lab, it’d be much appreciated if someone could link those