GL-MT1300 Beryl Repeater Not Working On Unifi Network

Hello. I have a GL-MT1300 with firmware 3.215. When I configure repeater mode to connect to my home network it does not pass internet. Looking for some help.

Network Setup:
Pakedge RK-1 Router
Unifi USW-Pro-48-PoE Gigabit Network Switch
(2) Unifi U6-LR Access Points

I am able to scan and find the SSID of my home network. I am able to use the WPA2 Key and click join and after about 10 seconds it says “Success!” in green at the top. I have verifed the GL-MT1300 is connected in the Unifi software and can verify the signal strength is strong.

Any device I connect to the GL-MT1300’s wifi will connect successfully, but internet does not work. As a test I “forgot” my home network and connected it to my iPhone 14 Pro as a hotspot, works perfectly fine. So I know the GL-MT1300 is configured properly.

Here is my concern. I am setting this up and testing before traveling. I have setup hotels with Unfi before so I know I may run into a Unifi network in the wild while traveling. Can anyone shed some light on why this GL-MT1300 will not working on this Unifi network? Is there anythign I can adjust to get it to pass internet properly? Thank you!

Is a device that is connected to the GL-MT1300 able to access and/or ping any of the other devices on the LAN (e.g., router, switch, access point, computer), even though it cannot access the Internet? Are there any settings on the router that could block outbound traffic?

Is the GL-MT1300 connecting over the 5GHz or 2.4GHz band? A number of users have reported problems with band steering enabled on Unifi access points, so make sure that band steering is disabled.

I do not work for and I am not directly associated with GL.iNet

Hello. Devices connected to the Beryl cannot see any local devices on the Unifi network. I have not adjusted any settings on the router that would block traffic. Infact if I hardware the Beryl into the Unifi network switch it works fine. I have tried the Beryl on both 5GHz and 2.4GHz as well as on the primary SSID and the guest SSID, same result of no internet and no traffic to primary network when in repeater mode.

Yes I have noticed on other forums that band steering may be part of the issue, but that doesn’t help in my case. This router is for travel only, so I would not be able to change the hotels network setup. I was more wondering if this is a documented known issue and this unit just will not work for my purposes or if there was a way to adjust it’s own settings to get it to work in any “typical” environment. With the popularity of Unifi and with Band Steering on “default” i would say it would be considered pretty typical.

In the discussions, band steering affect 2.4G wifi, not 5G wifi.

What is your firmware version? First upgrade to 3.215.

If does not work, upgrade to 4.1 beta (attention, settings will be lost).