GL-MT1300 / Beryl - WiFi clients cannot connect

Hi Guys,

I fetched my Beryl from oblivion, did a factory reset and initial setup. Everything worked fine. After firmware update to 3.211,the internet performance increased (nearly gigabit download is possible!!), but I wasn’t able to connect any WiFi device. SSID was shown, but no device could login. I switched to beta 3.215, but no success, too.
Now I’m back at 3.200 with half internet speed (~450 MBit/s), but every WiFi client is able to connect. Do you face any issues like this as well?

What channel is WiFi connected to? If “Auto” try changing 2.4Ghz to 1, 6 or 11 and 5.0 to 42 and see if that assists.


Thanks for your reply!! Yes, with this setting I was able to connect to WiFi, but only with default SSID/password credentials. After I customized SSID/password, I was not able to connect again. Then I switched from WPA2+WPA3 to WPA2 only and it worked again. I tried this setting also but with channels on “auto”. From my point of view, a combination of both settings did the trick.
Thanks a lot for your input!!