GL-MT1300 Can't access setup screen

Unpacked my GL-MT1300, connected the power, connected via wi-fi to GL-MT1300-ba1. Tried to connect to, got " took too long to respond" error. Tried a direct LAN connection - same thing. Disabled my security software on Windows - same error. Tried resetting the router to factory defaults, same error. I must be overlooking something.

Suggestions please. Thank you.

If it says took to long to respound means it is still starting up so give it 5min I would say. It if is connected to a WAN it should setup pretty quickly and you get a solid White light. If it is not connected will flash blue and tack a little bit because of no dhcp.

Try a private browser window and a wired connection. Note: If your browser always redirects to LuCI (, you can visit: instead of

If that does not work try CMD command in windows, then ipconfig and get the default gateway (should be maybe different)

DNS cache might need to be cleared so in CMD line enter ipconfig /flushdns

:gl_emoji_dizzy:I do not work for and I am not directly associated with GL.iNet :gl_emoji_shacking:

Thank you for your reply.

If it says took to long to respound means it is still starting up so give it 5min
Once the error message comes up after about 2 minutes of trying, the browser stops trying to connect. I can wait an hour and nothing further will happen. The unit is flashing a slow blue. I don’t know what “tack a little bit” means.

The private browser window doesn’t redirect to anywhere. It just comes back with a message that the ip address took too long to respond after about 1 minute.

The ipconfig for the LAN adapter shows a blank DHCP address. - even after I do the flushdns

The solution was much simpler. I had my ethernet cable plugged into the WAN port on the device instead of a LAN port. Once I corrected that I was able to connect to the set up screen and get logged in to my main wireless network.

Then on my laptop I was able to connect with the MT1300 wireless SSID with no problem. I have been running on it for about an hour now with no issues.

However, on my desktop, when I try to connect to the same MT1300 SSID that is working on my laptop, I got connected, but the status in Windows says No Internet. Why is the same SSID working on one computer but not on the other?

Thank you for your efforts.

If you didn’t block the desktop in MT1300’s client list, then it is strange.

I finally did get my desktop to connect. I have 2 wi-fi adapters on it. I used a different one than I used at first and it worked.

Thank you.

Do you mean one wifi adapter is defective? I cannot undersand the root reason of the issue.

Both adapters are functional. In normal use in my office, they are connected to different AP in my home office for redundancy/backup purposes.