GL-MT1300 Issues connecting to Wifi


Been having some issues connecting my MT1300 (Beryl) to a wi fi network whilst travelling.

I tested it by hot spotting a phone and on my home network prior without any issues on my home network, using firmware 3.211 (stable)

When I try to connect to this Wi-Fi network I get wrong key every time even though it is the correct credentials and tested on other devices without issue. I have tried with DNS rebinding attack protection on and off, still get the same error.

After looking at the post related to this on the forum there is some discussion around using different firm ware versions. I reset to factory defaults when changing firmware’s each time. The Wi-Fi network has username and password login requirements.

reverting firmware tested:
3.200 (no username box displayed unable to attempt login)
3.203 (also no username box)

Beta firmware tested:
3.215 (same issues as 3.211 just says wrong key after spinning for 20 secs)

Aft that I considered it may have been the Wi-Fi at hot spotting a phone still works for the Wi-Fi.

I sued a friends GL-AR750S-EXT and it connected without any issues.

Just wondering is this an issue swath the MT1300 or how should I best go about further troubleshooting, would the Logs be helpful?

Hopefully that is enough to go on, first time posting.

Thanks in advance for any help.

MT1300 and MT300N-V2, firmware 3.x does not support EAP wifi network, i.e. wifi network requires usenrame and password.

1 Like