GL-MT1300 LED control instructions

It needs to be 4.x firmware. Can you clarify your firmware version?

According to the status page in LuCI, Kernel Version is 4.14.241 and OpenWrt 19.07.8 r11364-ef56c85848. The Admin Panel’s upgrade section shows 3.215 as the installed version.

You should upgrade to 4.2

OK, the LED controls worked! Thanks!

I had used this trick to dim the LEDs, but with the upgrade, /usr/bin/mt1300_led is no longer there. Is it possible to dim the LEDs another way? I didn’t see a way within the app, control panel, or LuCI. Is there another file?

The two commands should still work, right?

Like I said, /usr/bin/mt1300_led isn’t present after the upgrade. Where would I edit/add those commands?


I’ll have to give up - The openwrt-mt1300-4.2.0-0210-1675977894 and today’s 0212 daily snapshot firmware just wasn’t stable. It would work at first, but at times it would not properly boot at power up, wouldn’t reset holding the button for 10 seconds, and required reloading firmware, I’ll just wait for the stable release. Thanks!

Have you gone back to old firmware and it worked good?

It is more like a power adapter issue.

Yes, I’d tried several different v4 firmware snapshots (going back to v3, then loading again), but had odd problems with each v4 load. Sometimes, the LuCI would error, other times, it was rebooting only from power off or not setting up standard options like OpenVPN. Finally, I had the no reset error.

It doesn’t seem to be a power problem because I used it for several hours on the current v3 firmware without a hiccup. I was powering it on my laptop USB, but had switched back to the original power supply, with no change.

Thanks for the help!


Thanks for this info.

My data:

FW Admin 4.2.0 Snapshot
OpenWrt: 22.03.2 r19803-9a599fee93 / LuCI openwrt-22.03 branchgit-22.288.45147-96ec0cd

I have a problem:

Test “Beryl GL-MT-1300”

Network interfaces: “WWAN” (iPhone WLAN 5GHz hotspot connection)

Device: Unspecified changed to WiFi network: Client “iPhone Pro Max S.H.” (wwan)

Everything else has not changed

LED configuration:

Test White LED On: (sys. standard) “can be switched off in the APP via cloud”


Trigger: Network adapter activity (Kernel:netdev)

Device: WLAN network: Client “iPhone Pro Max SH.” (wwan) / Were also changed as a test, works the same way

Trigger Mechanism: All have been tested

When saving & using, does it only work for a short time and then it’s gone again, whether Blue LED or Witte LED, the interfaces have also been changed for testing, right in the game?
Doesn’t work after switching off (power) and on again?

Test White LED Off: “Can be turned off in the APP via Cloud”

It works when the router is on, no matter if the LED is white or the LED is blue

Doesn’t work after switching off (power) and on again?

You probably have to program it via SSH, so you can also adjust the brightness of the LED?

Kind greeting
Sven H

It was further up the conversation - If you’re on the current stable (v3…) firmware, the file you need to modify is /usr/bin/mt1300_led.

The line you need to edit in the current stable is:
i2cset -f -y 0 0x30 0x06 0x3f
i2cset -f -y 0 0x30 0x07 0x7f

The top line is blue, the 2nd line is white (I think). Modify the last two digits to smaller numbers to dim the lights. I used 0x0f for both numbers.

On the daily (V4…) firmware, the file is /usr/bin/gl_i2c_led. You’ll need to add those two lines at the bottom of the file to limit the brightness.


Thank you very much.
So via SSH, if I have time for it I will do it that way!
Excuse me, my English is not good.
Unfortunately, you only understood me partially.

I tried it via SSH but nothing happened. Null Sero.
See picture please, only this is what I get via SSH.
No matter what I enter and restart, nothing happens.

I’ll try to keep it short in the text, maybe you understand me better!?

LED (white) should be on when booting blinking (default is blue LED)
If there is a connection with WWLAN, the blue LED should be on/flashing when data is being transferred (just like a network LED does/indicates this on the switch).
If this connection is interrupted, the white LED can flash again.

To the FW. 4.2.0 Snapshots:

When Beryl restarts or starts from cold boot, all LED settings are not effective, do they not work?
You always have to push yourself differently under LuCI Doesn’t it work?

Hope you understand now what I want?

Kind greeting
Sven H.
Bildschirmfoto 2023-03-03 um 19.05.48

Off is not correct because the LEDs are on (system standard)
I reset it again LED is on again but SSH says off (after reboot)?


I have one more request for GL-iNet: LED control

Under “luci/System/LED Config.”

GL-MT13000 (Berly) I have the FW. 4.1.0 on it, since it’s the only FW. is where it works 100%.
GL-MT3000 (Berly AX) there is currently no FW. where does it work?

LED config. Create and Save = Yes
After restarting (on the power as well as disconnected from the power) the devices are still there but have no effect. It doesn’t work?
You have to go back to Luci/Systen/LED Config. and make changes, then it works again.
This attitude is very important to me.
Please fix, thanks!

Or is there a way to do it via SSH if yes?
Please show me the way, thanks!

Sven H.

/etc/init.d/gl_led disable
1 Like


Thanks for the info.
No, I don’t want to turn off the LED, please see above, thanks!
Pictures say more than words, put the pictures in here again.
There you can see what I want with the Berly & Berly AX!

Property with both now the FW. Snapshot (Current) Install…
It doesn’t work with the Berly, only flashes briefly and goes into standard config. back.
With the Berly AX does it work but after a restart this setting no longer works?
Please fix this, thanks!

Sven H.

Pls try the command;

/etc/init.d/gl_led stop
/etc/init.d/gl_led disable

GLiNet use /etc/init.d/gl_led to control led by default;

OpenWrt use /etc/init.d/led to control led;

Now that you use OpenWrt’s way to control the led, you need to diable the GLiNet’s control process.



Thank you for the information.
I didn’t know that.
Will test it, then give Beseid!

You helped me a lot, thank you.
Works perfect.

Sven H.

For V4, If you edit ‘/usr/bin/gl_i2c_led’ and add the cammands at the end, you end with flashes at some intervals.

The best is to edit /lib/functions/, and modify the values in the function i2c_led_brightness (which is referenced in ‘/usr/bin/gl_i2c_led’)

To have low brightness, you can replace

i2cset  -f -y 0 0x30 0x06 0x3f
i2cset  -f -y 0 0x30 0x07 0x7f


i2cset  -f -y 0 0x30 0x06 0x07
i2cset  -f -y 0 0x30 0x07 0x0f