GL-MT1300 normally working, but led light solid blue, expected solid white

Dear support,

Been using the Beryl GL-MT1300 as Wifi/fixed router (wireguard client) since July 2022 without issues.

Last week it got stock after a config change, and I (accidentally) performed a factory reset. Then I restored the config from a backup file, and it seems to work as expected again.

But what I noticed is that the led light stays solid blue now, (after being booted up), but networking/the router seems to function normally.

In the documentation I saw:

  • Solid blue light: Device is powering up.
  • Solid white light: Network is connected.

I also remember that the light was normally solid white before when booted up.

Could you please point me to where to look on the router to troubleshoot this “issue”/ or what info to provide?

P.s. I saw a forum item about power supply issues, but I tried another 3A power supply and the light also stays solid blue when networking seems to work normally.

Thanks in advance, kind regards, Guido

Can you post what is the firmware version? 3.215 or 4.x?

The LED should be white.


Thank you for the quick reply!


Current Version


Compile Time

2022-09-21 11:49:49

Last Update



Please let me know what I can check in the CLI/shell.

Regards, Guido

Please try the command to turn on the led:

/etc/init.d/led enable
/etc/init.d/led restart

then, check to see if gl_mt1300_led_daemon is already running

root@GL-MT1300:/# ps | grep led
21981 root      1232 S    grep led
22841 root      1240 S    /bin/sh /usr/bin/gl_mt1300_led_daemon

root@iPhone:~# # right after bootup: router seems to work

root@iPhone:~# ps | grep -i led
28674 root 1232 S grep -i led

root@iPhone:~# /etc/init.d/led enable
root@iPhone:~# /etc/init.d/led start

root@iPhone:~# ps | grep -i led
30690 root 1232 S grep -i led

what I also notice is that the light doesn’t turn off anymore by:

root@iPhone:~# /etc/init.d/led stop

But I guess this is because the led service does not seem to start anymore?

“led status” does not seem to be a thing for this service, any other way/place to find errors for this?

p.s. yes, hostname is “iPhone” :wink:

copy the led program from rom, then execute it again

cp /rom/usr/bin/mt1300_led /usr/bin/
cp /rom/usr/bin/gl_mt1300_led_daemon  /usr/bin/
cp /rom/etc/init.d/led  /etc/init.d/
/etc/init.d/led enable
/etc/init.d/led restart

Great, that fixed it, thank you!