GL-MT1300 - OpenVPN - Local Network Access

I might be describing a few of these things inaccurately so I apologize for any ignorance.

I am attempting to setup a GL-MT1300 to connect to a OpenVPN access server in order to be able to connect to it remotely and access local network devices connected to the router.

Me(Remote Client) ----- Internet ----- OpenVPN Access Server ------- Internet ---- MT1300 - Device

From what I can tell I have configured the OpenVPN Access server correctly, both the MT1300, and client PC are able to connect and I’m then able to connect to the router remotely using the Routers VPN IP address, but I am unable to ping/access any of the devices connected to the router.
I do have “Access to local network” enabled.

I guess my question is, is there a way to setup IP forwarding to route traffic from the VPN gateway address to the routers gateway, and or a specific device?

Any help is welcome, thanks for taking the time to read this.

Several solutions for remote access

1. VPN and port forward

You enabled “Local network access”, it just means that MT1300 can be accessed from your vpn server.

If you want to access devices behind MT1300, you may need further iptables setting. You may just use port forward on MT1300 to your device? This seems easier.

2. Goodcloud managed S2S solution

The second solution is use our GoodCloud managed solution.

3. OpenVpn bridge

The third solution is use Openvpn bridge. In the ovpn you need to use tap and all the device connected to MT1300 will get IP from your ovpn server. You need to set up your server to enable bridge accordingly.

Here is the guide to set up vpn bridge.
https://docs.gl-inet.com/en/3/app/openvpn/#openvpn-bridge

4. Astrorelay

The forth solution for remote access is use our Astrorelay solution. In this way, you do not need to use vpn. You just need to install astrorelay client on MT1300 and you can make links to access your devices.

www.astrorelay.com

@alzhao Do you have a tutorial how to manage iptables and set port forwarding correct? I tried it many times, but it doesnt work for me

When set up port forward, just choose the correct external zone.