GL-MT1300 stops working after a couple of days connected


According to the log, the device has been rebooting repeatedly instead of crashing.
Do you have any special network configuration?

I think it may be caused by hardware NAT offload. Please run the following command to disable the hardware NAT offload function of the router.

uci set firewall.@defaults[0].flow_offloading='0'
uci set firewall.@defaults[0].flow_offloading_hw='0'
uci commit
fw3 reload
1 Like

Will try and let you know if any improvements.

Still the same after disabling firewall offload:
uci show firewall | grep flow
firewall.@defaults[0].flow_offloading=‘0’
firewall.@defaults[0].flow_offloading_hw=‘0’

<0>[ 1284.348260] Kernel panic - not syncing: Fatal exception
last.zip (12.7 KB)

<1>[ 1283.876010] CPU 1 Unable to handle kernel paging request at virtual address 00000020, epc == 80132900, ra == 801328d4

<4>[ 1283.889137] CPU: 1 PID: 3601 Comm: gltertf Not tainted 4.14.221 #0

gltertf is one thing whcih was rather changed (that is at least the stuff I was using to erase from orphaned client list in early release 3.200). It also seem to have a lot of changes since early version…

Any option to stop glterf from launching (or it is being used by another processes)

What is about gltertf: service gl_tertf stop - why is it trying to load ipv6 while is not enabled:
cp: can’t stat ‘/tmp/tertf/traffic_info_bak’: No such file or directory
Warning: Section @zone[1] (wan) cannot resolve device of network ‘wan6’
Warning: Option ‘wireguard’.masq6 is unknown
Warning: Option ‘sambasharewan’.dest_proto is unknown
Warning: Section ‘sambasharewan’ does not specify a protocol, assuming TCP+UDP
Warning: Option ‘sambasharelan’.dest_proto is unknown
Warning: Section ‘sambasharelan’ does not specify a protocol, assuming TCP+UDP
Warning: Option @redirect[0].gl is unknown

  • Populating IPv6 nat table
    Warning: fw3_ipt_rule_append(): Can’t find target ‘prerouting_lan_rule’
    Warning: fw3_ipt_rule_append(): Can’t find target ‘postrouting_lan_rule’
    Warning: fw3_ipt_rule_append(): Can’t find target ‘prerouting_wan_rule’
    Warning: fw3_ipt_rule_append(): Can’t find target ‘postrouting_wan_rule’
    Warning: fw3_ipt_rule_append(): Can’t find target ‘prerouting_guestzone_rule’
    Warning: fw3_ipt_rule_append(): Can’t find target ‘postrouting_guestzone_rule’
    Warning: fw3_ipt_rule_append(): Can’t find target ‘prerouting_wireguard_rule’
    Warning: fw3_ipt_rule_append(): Can’t find target ‘postrouting_wireguard_rule’
    Warning: fw3_ipt_rule_append(): Can’t find target ‘prerouting_allpermit_rule’
    Warning: fw3_ipt_rule_append(): Can’t find target ‘postrouting_allpermit_rule’
    Warning: fw3_ipt_rule_append(): Can’t find target ‘prerouting_rule’
    Warning: fw3_ipt_rule_append(): Can’t find target ‘postrouting_rule’
  • Running script ‘/etc/firewall.user’
    uci: Entry not found
    uci: Entry not found
    iptables: No chain/target/match by that name.
    iptables: No chain/target/match by that name.
    iptables: No chain/target/match by that name.

This is a very useful message, I think it is multithreaded processing Linux pipeline caused by the exception, please try to close the system using the most frequent pipeline program, execute the following command.

/etc/init.d/gl_tertf stop
/etc/init.d/gl_tertf disable

The above command will disable the client statistics and offline client record functions. If you want to enable them again, use the following command

/etc/init.d/gl_tertf enable
/etc/init.d/gl_tertf start

I have did something new. Resigned from ISP’s given router/modem and used Huawei OTP box.
Unfortunatelly my ISP have PPPoE + VLAN tag. So while gl.inet support PPPoE it doesn’t work out of the box and I need to dig into LUCI anyway (switch setup). Bad thing is that default tag is set to 2 (eth0.2) so needed to manually edit /etc/config/network.

config interface ‘wan’
option hostname ‘GL-MT1300-3f8’
option metric ‘10’
option proto ‘pppoe’
option username ‘XXXXXXXXX’
option password ‘XXXXXXXXX’
option disabled ‘0’
option ifname 'eth0.35’
option ipv6 ‘1’
option delegate ‘0’

config interface ‘wan6’
option proto ‘dhcpv6’
option reqprefix ‘auto’
option reqaddress ‘try’
option ifname ‘@wan
option disabled ‘0’

config switch
option name ‘switch0’
option reset ‘1’
option enable_vlan ‘1’

config switch_vlan
option device ‘switch0’
option vlan ‘1’
option ports ‘6t 0 1 2 3’
option vid ‘1’

config switch_vlan
option device ‘switch0’
option vlan ‘2’
option ports ‘6t 4t’
option vid ‘35’

Also removed custom config for wireguard and asked friend in NewZeland to buy gl.inet to spin it into goodcloud. Also removed dhcp option 6 remove push domain server and did it through tagging (no need for washing machine or air conditioning to query domain controller)

1 Like

Does your configuration work properly? Can I help you?
Vlan Settings will be supported in future 4.x firmware.

1 Like

What actually worked was to replace unit with GL-S1300
Same config (used luci clone) - working as VPN concentrator for 3 other sites: online for last 7 days and no hicckups (reboots)
I think that GL-MT1300 require a lot more stability fixes. Is fine with small number of devices connected (up to 5-10 active) - but problems start with more complex (60+ devices + a lot of traffic). Performance of MT13000 is fine. Just stability far from good.

Any luck in making router reboot instead freeze? Reboots (although not welcome) are tolerable: complete freeze is just worst scenario ever…

Can you try the 3.211 beta firmware https://dl.gl-inet.com/firmware/snapshots/3.211_beta1/mt1300-newdriver/

Fixed a lot of problem recently.

I have the same exact router and the same setup. Ethernet to wan and then use the wifi off the router. No VPN etc. But it drops many many times a day. I’ve tried a reset on it and on the Netgear M1 I’m using as well. I can use the Netgear M1 plugged into pretty much any other router but this one for some reason and it works flawlessly. I bought this one for its size etc. Did you all ever find any solutions?

First, pls try 3.211 firmware.

Then, if not fixed, send me the log. You can ssh to the router and use “logread”.

I’ve had that installed since it was available. It just drops connection to the router no matter what I try. I’ve tried tethering with a data usb-c 3.0, I’ve tried with an ethernet cord as well. the only way I can use it at all is if I use it as an access point and not a router. Which doesn’t give me the control I need. (I have no idea how to do the SSH you mentioned, I’m reading up on that now.)

About ssh SSH to the Router - GL.iNet Docs

Can you keep one thread so that the info is accurate.

How do you set up as access point and router?

Hi there, just bought the GL-MT1300 router and upgraded to the 3.211 firmware from the online upgrade interface.

I also experienced the same issues sastone75 mentioned. Setup:

  1. ethernet plugged into WAN
  2. 2 devices connected to LAN ports
  3. WIFI off
  4. all other settings on default (no VPN, etc - only simple router usage)
  5. Using standard electrical power (to the wall in hotel room), using factory power supply

My two devices are my computer and a streaming TV box. Unfortunately, the connection drops every few hours (sometimes sooner). When that happens, the router’s light sometimes flashes (but not all the time). I cannot access the admin webpage, ssh also no response. connected LAN devices will not get a response when trying to renew DHCP.

Power cycling the router will fix everything (until the same issue happens again in a few hours).

Any help would be greatly appreciated.

If the LED is solid blue, it may means that the device is rebooting.

Does it just hang or automatically reboot and start to work?

Seems kernel crashing causing it reboot.

Thanks for getting back to me.

The light is white. The issue happened again around an hour ago, and looks like it’s stuck there since. Still white light - cannot ssh, etc.

So, it’s hung.

its like the new firmware’s arent good, only the august 2021 has been the most stable. I have 2 mifi devices and one USB LTE modem that is load balance with MWAN3. For the life of me, this thing will not stay working after a few days of usage. I’ve been tracking with influx and grafana, I don’t thin the CPU and memory usage should be this high…

1 Like

I’m facing a very similar issue (exact same stacktrace). I’d be interested in solution for that too.