GL-MT1300 WiFi but no internet

I’ve been using my mt1300 for a few months now and with very good results until a month ago or so when tethering to my iPhone (or repeater mode to iPhone hotspot) speeds dropped.
I forgot the problem and stuck to only using it with other Wifi networks in repeat mode instead of my phone, until yesterday.
I cannot get internet connection out of my Beryl wifi, I can connect to both SSIDs but get zero internet, if I connect to the beryl via lan cable I Get internet just fine (still in repeater mode).

I’ve tried resetting the router, restoring it, upgrading firmware, downgrading, turning of one SSID, etc, nothing still no internet.
VPN kill switch is off.

Any ideas???

Recently did you upgrade firmware?

3.203 use an old wifi driver, has some bugs, but it works OK with iphone.

3.211 use an new wifi driver, fixed some bugs but introduced some other bugs with iphone.

3.212 snapshot from May 12 finally fixed these bugs GL.iNet download center but may still have problem with fritzbox.

1 Like

Updated to 3.212 WiFi works but when I tether to iPhone speeds drop to a crawl, 0.2/05 mbps

Did you test both USB tethering and wifi repeater?

Yes both. Same speeds