GL-MT2500 / Brume 2 HW Acceleration with VLAN tagging

I am using the Brume 2 as router while being directly connected to my ISPs fiber converter which requires tagging with and ID of 101. I have created a 802.1q VLAN with the ID and assigned WAN to it.
This works fine, however only if HW acceleration is disabled. If enabled, connections are randomly dropped and act very unstable e.g. wikipedia pages load very slowly.

The issue is that without HW acceleration is it not possible to reach a speed of 1 Gbit/s while it is possible with it enabled.

Is this just expected behavior with a software VLAN or some kind of bug?

I was looking up Brume 2 hardware acceleration today and in the manual it looks different in firmware 4.3 which doesn’t seem to exist. It’s on/off/auto where we just have on/off

Firmware 4.5 is available as snapshot at GL.iNet download center

Yes fair enough but if the docs talk about 4.3 then you would think it’s out stable. Sounds like there won’t even be a 4.3…

Brume2 will skip 4.3 and go straight to 4.4.5 and 4.5.
However, the software acceleration works on Cellular. So you need to have a USB Modem for this feature to work.

Thank you for the reply.

So HW acceleration does not work on a vlan tagged WAN?

We haven’t tested it, It may not work.
When upgrading to 4.5, however, you can configure VLAN ID for Ethernet directly from the GL UI.

Where is this feature? I updated my Brume2 to 4.5 but I don’t see the vlan page.

There is no dedicated VLAN page. You can enter the VLAN ID when modifying your Ethernet connection on the Internet page.

I need it for the LAN side.

Luci is your friend.

You have a guide? :sweat_smile: I’m lost.

Go to luci and find Switch settings.

Note: Image is from AXT1800.

1 Like