GL-MT2500 NordVPN connected to VPN but no Internet Connection


Thank you already for your time and help. I have a GL-MT2500 device and connecting to openvpn from NordVPN, both lights are solid on the device and I see it is connected with a NordVPN IP. But when I try to connect through the LAN port, I get no Internet. It used to work until a day ago. I have factory reset the device and deleted the VPN and re added it, even used the login for NordVPN on the device settings. It does connect the device, I can even remote access it from but no Internet on LAN port. I get an IP from the device and even see the device connected on the LAN port on the settings device. When I turn off the VPN and back on, it seems to work. But then when it power cycles again, it stops. I changed the VPN to Surfshark wireguard and everything seems to work. Running the new v4.2.0 firmware, also tried to reverse to previous one, still no internet.

What could be the issue?


This is a bug when doing sysupgrade with keep setting.
For a temporary workaround:

cp /rom/etc/openvpn/scripts/ovpnclient-up /etc/openvpn/scripts/ovpnclient-up
cp /rom/etc/openvpn/scripts/ovpnclient-down /etc/openvpn/scripts/ovpnclient-down 

If you changed ovpnclient-up & ovpnclient-down manually, make a backup before issue that command please.