GL-MT2500 Uboot not working

My GL-MT2500 can no longer be reached.
I have the firmware via Uboot, I was able to install the new firmware openwrt-mt2500-4.6.2-0628-1719560735.bin.
But after booting, the router cannot be reached via 192.168.8.1. The PC client has a random IP
Thank You

Set the up your client manually.
Different depending on clients but it's pretty straight forward on a Windows machine. Find your ethernet or WiFi network adapter settings (can be found sometimes by right clicking the icons near the clock - right click "network settings") on Windows 11 you can search for "WiFi Settings" or "Ethernet Settings" and change from "automatic DHCP" to manual / static.

IP address: 192.168.8.199
Subnet mask: 255.255.255.0
Gateway: 192.168.8.1
Preferred DNS: 192.168.8.1

Save/apply - then visit the router IP

Thank you for the reply, but even after following the instructions I cannot access the router

Disconnect the brume from WAN and LAN - reboot the brume 2. Clear all your browser cache, run CMD (command prompt) and type:

ipconfig /flushdns

reboot your client device and then manually enter the static IP information I listed above again. Once done connect an ethernet cable to the brume 2 via it's LAN port (keep WAN empty) connect the other side to the client (Windows laptop / desktop) to it's ethernet port

Then try and visit the IP of the router. Also make sure that browser isn't trying to load https if you see that in the URL just change it to http.

If it's still not showing the GUI and you have set the correct static IP range on your device and everything is setup correct then try and load CMD and ping the device:

ping 192.168.8.1

See if you get a response.

1 Like

I’m having the same issue on the same router, I can update/login to the router through Uboot but after I install the firmware the router is inaccessible normally. Only Uboot mode is accessible, regular booting of the router has a blue light and 192.168.8.1 says site cannot be reached. Ping also times out/destination host unreachable even with manual assigning IP. I’ve tried downgrading with uboot but that doesn’t work either.

For me this sounds like an issue with the flashing process. Can you retry to flash the newest firmware?
What kind of connection and system (Windows, Linux, Mac) do you use while running Uboot?

I've tried flashing it through uboot multiple times, I've tried the latest FW, the Snapshot build (4.7) and some older builds including the original build. They all seem to flash fine, just when it reboots it never seems to get to the admin page and the light stays blue, which is supposed to mean the device is still booting.

@Bruce may you have a look?

@ j2zero
I have followed your instructions exactly.
The router is still not accessible
The ping is lost.

@tom233
Please try to enter the uboot mode and flash the latest firmware as below:

@dnlsmy
Please contact our support team: support@glinet.biz

1 Like

What is the LED status?

I contacted support and they are replacing my unit with the MT2500A since the non-A version is discontinued. Thanks for your help!

1 Like

I have now installed the latest firmware and the snapshot firmware.
The router is not accessible with both.
The LED is blue.

Pls contact support at glinet.biz