Gl mt300 v2 nat problem xbox

Hello there,

I just got a GL MT300 V2 but using it in order to tethering my android hotspot and connect by ethernet to xbox one.
However I still have a problem with NAT: in general the xbox see as a double NAT detected.

I tried every step without solve the problem, I eeven downgrade the firmware in order to have the chance to open the UPNP.

Do you have any solution?

you can use DMZ option, and you can try port forwarding too. Try and write to the forum.

Hi Did you find a fix ?
I have a similar issue where I have a “strict NAT”.
I am in router mode, with a cable plugged from my ISP modem/router to the Mango v2 and the wireguard vpn setup on it and wired to the xbox (I tested wireless also).
when I activate the wireguard VPN I get a “strict Nat” when I deactivate I get a “open NAT”, can anyone advise should it be possible to get a “open NAT” with the wireguard vpn activated? which is the whole idea why I wanted the mango v2.
I have tried the port forwarding & DMZ with no success. In bridging mode it does change to “open NAT” but I lose the vpn capability which again defeats the purpose.

anyone any advice?

too add & for reference testing the xbox X & the mango v2 in cable/router mode & connecting wireless to xbox x…

  • I get “open NAT” with openvpn config file (Shared IP addresses mode (NAT) has all its ports closed) no port forwarding required, but the speed is down to 8mpbs up & down

  • I get “strict NAT” with openvpn config file (public IP addresses mode has all its ports opened)

  • I get a “strict NAT” with wireguard, alot better speeds 20mpbs up 28mpbs down.

I wonder if you can get the open NAT working with wireguard ?

Hi found a partial solution to the problem:

for avoid the UPNP unavailable, I downgrade the firmware to the version 2.26 where there is the option to unable them.

Then I connected the phone tethering by USB and the XBOx by ethernet and NAT is open and fast enough.

I would like to have another solution even using WIFI, but in that case I always encountered problems with NAT.


I just got the GL-SFT1200 and I’m having the same problem. I haven’t tried anything yet as I normally search to see if there was a work around for it.

xbox relays in IPV4. So if your ISP only provide IPV6, xbox may have problems.

As far as I know the Xbox is using IPv6 native. With the Tredo protocol it will tunneling IPv6 over IPv4, if no IPv6 is available. A very huge security issue, because you have no chance to configure/secure this tunnel, am attacker who claims to be Microsoft is able to use the Xbox as hopper to your network … In theory, this for another day. Back to topic:

The Xbox indeed needs some open ports. Put the Xbox in DMZ, as ‘Exposed Host’ or whatever you’ll call it could work. But I strongly recommend to forward only the needed ports.

Port forward:

88 UDP
3074 TCP/UDP
3544 UDP
[Alternate Port]* TCP/UDP

(* The ‘Alternate Port’ that depends on the user. Regular the Xbox will negotiate a Port itself and use it for Multiplayer or Chat and so on. But you can set it to a fixed port per user.
On the Xbox Settings: Network Settings - Advanced Settings - Alternate port selection. Here you can select one from a bunch of port numbers. It needs to be forwarded in TCP and UDP. One port per Xbox-User)

Upnp never worked for me, with different routers. Maybe one time during setup/testing, but never reliable.

1 Like