GL-MT300 WireGuard Server issue

First, apologies I this post is a duplicate, I thought I had clicked on “Create Topic” and I don’t know what append to the post.
I have my GL-MT300 connected to my modem and an Orbi connected to the GL-MT300 on its WAN port.
The connectivity is fine, the GL-MT300 assigns DHCP with a range of to, the Orbi has a fixed IP of
Each of them shows the correct IP on their respective admin page.
I was trying to set up the WireGuard Server by first enabling DDNS my ISP does provide me with a public IP.
Then, I generated a configuration file for my phone and scanned it into the WireGuard app on the phone.
The VPN connects immediately but I am not able to browse the internet while connected to that VPN.
Of course I disconnected the Wi-Fi on my phone and checked on cellular only.
Now, upon examining the settings of that config, I found out that the client (phone) was given an IP of, my Orbi is already using that IP, could that be the problem?
Below is the status of the client as it is connected to the WG server:
Oh… and I did allow access to LAN before generating the config.
Thanks in advance for any help.

Clients Status

Name Virtual IP Real IP

• Phone

^ 252.00 B
~ 16.21 KB

You should look in the WireGuard config file for the [Interface] → Address line to see if it is assigning IP address to the client device (phone). The VPN subnet should be different from the LAN subnet.

Most home networks use a 192.168.x.y Class C network on the LAN.

I do not work for and I do not have formal association with GL.iNet

I changed that default to for the Beryl, my Orbi uses

I just tried the OpenVPN server and it works flawlessly.
The WireGuard still connects bu no internet.

Below are the OpenVPN and WG Servers on my router
The OpenVPN has worked right away, WireGuard connects but no internet.
Both configs are using DDNS, I have enabled access to LAN and IP Masquerading was on by default.

My GL-MT3000 has an IP address of and there is an Orbi access point with a static IP of
The first client config generated by the router was assigning, I even created an additional one @ to make sure it was not conflicting with my Orbi, still no Internet.

The VPN subnet has to be different from the LAN subnet. Your Wireguard VPN IP of is on the same subnet as your router LAN IP of Your OpenVPN VPN subnet of is a different subnet.

Thank you, I actually found out this morning while I was looking at a video on the Brume GL-MV1000: the guy was setting up the WireGuard server for the first time and I saw that the server defaulted to which was exactly what it did for me.
The problem was that when I first set up my router, I had changed its default address from to
I just went ahead and changed the server config from to, create new client configs and boom!
Everything works. I have access to my LAN and to the internet.
Thanks again.