Gl-mt3000 4.1.2 : tethering (Huawei e3372h-320)

  1. tethering doesn’t auto-enable when power on
  2. glinet app shows tethering enabled, disabling it doesn’t do anything, so can’t disable reenable it
  3. got to login 192.168 to connect it every time power on

Tethering doesn’t show traffic data like when using USB modem mode, just a small convenience to have

Yes, it is currently designed to do so. Because this feature is also used to connect to a mobile phone as a temporary networking method. We are discussing optimising it.

It sounds like a bug, thanks for your feedback and we will check it.

Tried with slate ax 4.1 and glinet app

The tethering in the app always show as on, clicking the disable button will disable tethering with app

But since it still shows on, I can’t enable tethering with the app


The bug should be on the App 2.0 beta, not the firmware.
There is a problem with the enable tethering switch status. You click on the second line (Device eht2(iOS)) and it should set up correctly.

Can you also check enable cellular by manual setup whether it works? It doesnt attempt to connect when I tried with manual setting via app


this workaround works

but now , the tethering auto enables when i boot up the beryl … so confused…

Yes, we will check it.

Are you using the same USB modem?
Let me explain the problem more carefully.
There is a design flaw to be optimised here, our UI does not indicate the true enabled status. Tethering is actually dependent on two statuses:

  1. whether the logical interface is enabled or not
  2. whether the device is successfully connected

So, the so-called auto-enable does not exist and the enabled state of the interface does not change on reboot.
You can check LuCI → Interfaces to see if the Tethering interface is enabled. I suspect this is a connection problem with the USB Modem on reboot.

I observed the condition that tethering will resume when power on

It is when gl-mt3000 is also connected to a wisp (repeater enabled) before power off

another issue observed is on power up mt3000 keeps trying to connect to a wisp then is not available/online

so it keeps cycling the wifi on and off until i managed to disable wisp/repeater

Repeater will resume the status it was in before the reboot after boot. It does not disable Wi-Fi, in fact, it just switches channels. repeatater reconnect is detailed in: Repeater Reconnection.