GL-MT3000 Beryl AX - Firmware Issue?

Hi everyone,

I run two MT3000's for my travel set up. I was running 4.5 with no issues for months. I had to upgrade to 4.5.16 due to latency issues. After the update it appears my client device is leaking regional data from the client device.

The IP and WebRTC data look to have no leaks on the wire guard set up. Global proxy is also set to Block Non-VPN Traffic. To trouble shoot I have deleted both client profiles, server profiles, and reset both routers to factory. I then established a new server profile with dynamic DNS and created new wire guard keys, and on the client side established the new profile.

Yet again, IP, WebRTC data look to be clean. However, when on google and other program logs you can see the reginal data being picked up from the client device creating business issues.

Is this a Firmware issue? How to secure and force port data?

Side note, client devices, have all WIFI and bluetooth disabled, location tracking off.

Please help.

Can you check if leaks are detected here, here or here?

If none of them are leaking, then the IP databases just learned your VPN IP isn’t your true location.

Yes, all looks good at first sight no IP, DNS, or WebRTC leaks. All reports reflect the Wire Guard sever data. However, the reginal data when using programs and google reflect my real location.

Is there a way to assign a new IP to the client router if that is the case? Also seems odd issue only happened after update.

I would say you need to switch your WireGuard server for this. If it's a private one, you can't change anything.

I also installed a Mullvad Wire Guard to test if it was an issue with my other MT3000 server and it is creating the same issue. It appears to be an issue with the client MT3000 note issuing full global proxy and not blocking all non vpn traffic is my best guess.

Do you use any other software on your client, like a VPN or DNS software?

On the core router client no. On two client connected devices no. On the third client connected device - Yes, a Cisco VPN no pervious issues multi tunneling.

Note. I have tried with one client device connected and all of them connected at once. Issue is the same across all scenarios after firm ware update